aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2018-07-21 18:57:52 +0300
committerGitHub <noreply@github.com>2018-07-21 18:57:52 +0300
commitef409b726f578f1655702fec5e478372a8af27bf (patch)
tree9f66f134e59a8ad43cf8f7ac34c4fea2236798da /net
parent0edd0ee435997fc39e3983b4c1fac8ee3d202cc9 (diff)
parent8174576cdb533069caf05e943a386be020d862b8 (diff)
Merge pull request #6510 from Ansuel/nginxfix
nginx: add http_sub_module
Diffstat (limited to 'net')
-rw-r--r--net/nginx/Config.in5
-rw-r--r--net/nginx/Config_ssl.in5
-rw-r--r--net/nginx/Makefile7
3 files changed, 15 insertions, 2 deletions
diff --git a/net/nginx/Config.in b/net/nginx/Config.in
index 32e6d245b..2a8ce3389 100644
--- a/net/nginx/Config.in
+++ b/net/nginx/Config.in
@@ -202,6 +202,11 @@ config NGINX_HTTP_SECURE_LINK
prompt "Enable HTTP secure link module"
default n
+config NGINX_HTTP_SUB
+ bool
+ prompt "Enable HTTP sub module"
+ default n
+
config NGINX_HEADERS_MORE
bool
prompt "Enable Headers_more module"
diff --git a/net/nginx/Config_ssl.in b/net/nginx/Config_ssl.in
index 3b18dbbc9..4fc79016f 100644
--- a/net/nginx/Config_ssl.in
+++ b/net/nginx/Config_ssl.in
@@ -194,6 +194,11 @@ config NGINX_HTTP_SECURE_LINK
bool
prompt "Enable HTTP secure link module"
default n
+
+config NGINX_HTTP_SUB
+ bool
+ prompt "Enable HTTP sub module"
+ default n
config NGINX_HEADERS_MORE
bool
diff --git a/net/nginx/Makefile b/net/nginx/Makefile
index 7a74291ec..2c65ea72e 100644
--- a/net/nginx/Makefile
+++ b/net/nginx/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=nginx
PKG_VERSION:=1.15.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=nginx-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://nginx.org/download/
@@ -261,6 +261,9 @@ ifneq ($(BUILD_VARIANT),all-module)
ifeq ($(CONFIG_NGINX_HTTP_SECURE_LINK),y)
ADDITIONAL_MODULES += --with-http_secure_link_module
endif
+ ifeq ($(CONFIG_NGINX_HTTP_SUB),y)
+ ADDITIONAL_MODULES += --with-http_sub_module
+ endif
ifeq ($(CONFIG_NGINX_HEADERS_MORE),y)
ADDITIONAL_MODULES += --add-module=$(PKG_BUILD_DIR)/nginx-headers-more
endif
@@ -283,7 +286,7 @@ else
ADDITIONAL_MODULES += --with-http_ssl_module --add-module=$(PKG_BUILD_DIR)/nginx-naxsi/naxsi_src \
--add-module=$(PKG_BUILD_DIR)/lua-nginx --with-ipv6 --with-http_stub_status_module --with-http_flv_module \
--with-http_dav_module --with-http_auth_request_module --with-http_v2_module --with-http_realip_module \
- --with-http_secure_link_module --add-module=$(PKG_BUILD_DIR)/nginx-headers-more \
+ --with-http_secure_link_module --with-http_sub_module --add-module=$(PKG_BUILD_DIR)/nginx-headers-more \
--add-module=$(PKG_BUILD_DIR)/nginx-brotli --add-module=$(PKG_BUILD_DIR)/nginx-rtmp \
--add-module=$(PKG_BUILD_DIR)/nginx-ts
config_files += koi-utf koi-win win-utf fastcgi_params