aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorStan Grishin <stangri@melmac.ca>2022-12-07 20:59:28 +0000
committerStan Grishin <stangri@melmac.ca>2022-12-07 21:00:08 +0000
commitee37d0ec863a2254c4bfecd7bb65155e276fed88 (patch)
tree9f4734fadf2e22ba3d3a849d50b71b88b053d8ba /net
parentd6b712cde6c3094562e143df69a8cd600af52be1 (diff)
https-dns-proxy: add mdns service records
* add mdns records for started instances * Makefile: use $(PKG_VERSION) as a value for PKG_SOURCE_DATE instead of hard-coding it Signed-off-by: Stan Grishin <stangri@melmac.ca>
Diffstat (limited to 'net')
-rw-r--r--net/https-dns-proxy/Makefile4
-rwxr-xr-xnet/https-dns-proxy/files/https-dns-proxy.init1
2 files changed, 3 insertions, 2 deletions
diff --git a/net/https-dns-proxy/Makefile b/net/https-dns-proxy/Makefile
index 81b01e5b9..a91a3d1cd 100644
--- a/net/https-dns-proxy/Makefile
+++ b/net/https-dns-proxy/Makefile
@@ -2,11 +2,11 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=https-dns-proxy
PKG_VERSION:=2022-10-15
-PKG_RELEASE:=8
+PKG_RELEASE:=9
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/aarond10/https_dns_proxy/
-PKG_SOURCE_DATE:=2022-10-15
+PKG_SOURCE_DATE:=$(PKG_VERSION)
PKG_SOURCE_VERSION:=f52a85f3edabecfbab41d9244c63a1c6b8aaf49b
PKG_MIRROR_HASH:=dd8a55255e8859a462fcfd736577fec40731b39a4783325640518745009b0dee
PKG_MAINTAINER:=Stan Grishin <stangri@melmac.ca>
diff --git a/net/https-dns-proxy/files/https-dns-proxy.init b/net/https-dns-proxy/files/https-dns-proxy.init
index cae80f161..201ddadc7 100755
--- a/net/https-dns-proxy/files/https-dns-proxy.init
+++ b/net/https-dns-proxy/files/https-dns-proxy.init
@@ -153,6 +153,7 @@ start_instance() {
procd_set_param stdout 1
procd_set_param respawn
procd_open_data
+ procd_add_mdns_service "$packageName" 'udp' "$port" "DNS over HTTPS proxy"
json_add_string url "$url"
if [ "$force_dns" -ne 0 ]; then
json_add_array firewall