aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-05-09 19:50:12 -0700
committerGitHub <noreply@github.com>2020-05-09 19:50:12 -0700
commitea692188e0c285c98f84947eaf9f266d4ba18dc0 (patch)
treef5361f459cc4483d6b1cacae5344194ba314f734 /net
parent386f5b58e5c8ba908843d7e6ee49c88c811fad55 (diff)
parent3ef692e74df97b96222e3c84b0be9260664ac406 (diff)
Merge pull request #12099 from neheb/pdns
pdns-recursor: fix compilation with boost 1.73
Diffstat (limited to 'net')
-rw-r--r--net/pdns-recursor/Makefile2
-rw-r--r--net/pdns-recursor/patches/300-boost-173.patch21
2 files changed, 22 insertions, 1 deletions
diff --git a/net/pdns-recursor/Makefile b/net/pdns-recursor/Makefile
index b0bc0d448..a58087e14 100644
--- a/net/pdns-recursor/Makefile
+++ b/net/pdns-recursor/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=pdns-recursor
PKG_VERSION:=4.2.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://downloads.powerdns.com/releases/
diff --git a/net/pdns-recursor/patches/300-boost-173.patch b/net/pdns-recursor/patches/300-boost-173.patch
new file mode 100644
index 000000000..ecddd9d8d
--- /dev/null
+++ b/net/pdns-recursor/patches/300-boost-173.patch
@@ -0,0 +1,21 @@
+--- a/webserver.cc
++++ b/webserver.cc
+@@ -36,6 +36,8 @@
+ #include "uuid-utils.hh"
+ #include <yahttp/router.hpp>
+
++using namespace boost::placeholders;
++
+ json11::Json HttpRequest::json()
+ {
+ string err;
+--- a/ws-recursor.cc
++++ b/ws-recursor.cc
+@@ -45,6 +45,7 @@
+
+ extern thread_local FDMultiplexer* t_fdm;
+
++using namespace boost::placeholders;
+ using json11::Json;
+
+ void productServerStatisticsFetch(map<string,string>& out)