aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorHeath Kehoe <yaheath@gmail.com>2019-06-02 20:00:20 +0000
committerHeath Kehoe <yaheath@gmail.com>2019-06-03 03:19:07 +0000
commite86624e13bd2b45530000dceb977cda45266122d (patch)
tree3b2d46e8761320da1b946c29c4132455117248bb /net
parent72dc6f669a960c233a6d19af3806ba423387a01c (diff)
isc-dhcp: Remove --disable-tracing from configure args
This fixes a crash that happens when dhcpd is configured with a failover peer, and the failover peer goes down. The crash is due to a dereference of a freed object. When tracing is enabled (which is the default) the object in question is referenced by the tracing code and so doesn't get freed prematurely. I have observed this crash on two different target platforms (mips and x86_64), and it is reproducible on non-OpenWRT distros by building isc-dhcpd using --disable-tracing. This has been reported to ISC, but their response was that it's a low priority as the simple work-around is to leave tracing enabled. Re-enabling the tracing code only increases the size of the executable by about 24KB. Signed-off-by: Heath Kehoe <yaheath@gmail.com>
Diffstat (limited to 'net')
-rw-r--r--net/isc-dhcp/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/net/isc-dhcp/Makefile b/net/isc-dhcp/Makefile
index 2bb7ffb11..7c29f1b51 100644
--- a/net/isc-dhcp/Makefile
+++ b/net/isc-dhcp/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=isc-dhcp
UPSTREAM_NAME:=dhcp
PKG_VERSION:=4.4.1
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_LICENSE:=BSD-3-Clause
PKG_LICENSE_FILES:=LICENSE
@@ -161,7 +161,6 @@ $(call Package/isc-dhcp-omshell/description)
endef
CONFIGURE_ARGS += \
- --disable-tracing \
--enable-paranoia \
--disable-dependency-tracking \
--with-randomdev=/dev/urandom \