aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorMichal Vasilek <michal.vasilek@nic.cz>2021-08-05 14:26:29 +0200
committerMichal Vasilek <michal.vasilek@nic.cz>2021-08-09 09:35:23 +0200
commite7127d468490baeaa863b4ab817ac05ec74186fa (patch)
tree75da4a8a54e06f99aadc1bcb19faa290520dcaf5 /net
parent81e0fcb76fd886dd0188d5da341e6fb7c38677c5 (diff)
knot-resolver: update to version 5.4.0
* refresh patches * disable kres_gen_test to fix cross Signed-off-by: Michal Vasilek <michal.vasilek@nic.cz>
Diffstat (limited to 'net')
-rw-r--r--net/knot-resolver/Makefile8
-rw-r--r--net/knot-resolver/patches/030-fix-policy-hack.patch2
2 files changed, 6 insertions, 4 deletions
diff --git a/net/knot-resolver/Makefile b/net/knot-resolver/Makefile
index ea78b89ab..4d1ede85d 100644
--- a/net/knot-resolver/Makefile
+++ b/net/knot-resolver/Makefile
@@ -10,12 +10,12 @@ PKG_RELRO_FULL:=0
include $(TOPDIR)/rules.mk
PKG_NAME:=knot-resolver
-PKG_VERSION:=5.3.2
-PKG_RELEASE:=2
+PKG_VERSION:=5.4.0
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://secure.nic.cz/files/knot-resolver
-PKG_HASH:=8b6f447d5fe93422d4c129a2d4004a977369c3aa6e55258ead1cbd488bc01436
+PKG_HASH:=534af671b98433b23b57039acc9d7d3c100a4888a8cf9aeba36161774ca0815e
PKG_MAINTAINER:=Jan Pavlinec <jan.pavlinec1@gmail.com>
PKG_LICENSE:=GPL-3.0-later
@@ -57,6 +57,7 @@ define Package/knot-resolver/config
source "$(SOURCE)/Config.in"
endef
+# kres_gen_test breaks on cross, fix is already upstream
MESON_ARGS+= \
$(if $(CONFIG_PACKAGE_knot-resolver_dnstap), -Ddnstap=enabled,-Ddnstap=disabled) \
-Dcapng=disabled \
@@ -69,6 +70,7 @@ MESON_ARGS+= \
-Dkeyfile_default=/etc/knot-resolver/root.keys \
-Dprefix=/usr \
-Dunit_tests=disabled \
+ -Dkres_gen_test=false \
-Dutils=disabled
define Package/knot-resolver/install
diff --git a/net/knot-resolver/patches/030-fix-policy-hack.patch b/net/knot-resolver/patches/030-fix-policy-hack.patch
index a4eac6c8d..88f5c06d1 100644
--- a/net/knot-resolver/patches/030-fix-policy-hack.patch
+++ b/net/knot-resolver/patches/030-fix-policy-hack.patch
@@ -2,7 +2,7 @@ This patch fixes the problem with forwarding in knot-resolver v4.3.0.
It reintroduces a fix which enables policy related hack (knot/knot-resolver#205 (comment 94566) )
--- a/modules/policy/policy.lua
+++ b/modules/policy/policy.lua
-@@ -982,7 +982,7 @@ policy.layer = {
+@@ -984,7 +984,7 @@ policy.layer = {
if bit.band(state, bit.bor(kres.FAIL, kres.DONE)) ~= 0 then return state end
local qry = req:initial() -- same as :current() but more descriptive
return policy.evaluate(policy.rules, req, qry, state)