aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2022-02-08 09:25:02 +0000
committerYousong Zhou <yszhou4tech@gmail.com>2022-03-01 10:06:48 +0800
commite60310eb2ebf256efb60c6fb6841c3edb30467dc (patch)
treebeff37a9ac21a51f6b912d25b415c59d295c8ff4 /net
parent76967bdfb0e6cec922506f651418080f378b622f (diff)
shadowsocks-libev: ss-rules: request presence of nat table
ss-rules with iptables needs presence of netfilter nat table to work. ss-rules works before without explicitly requesting it as a dependency because it's present by default on a pre-firewall4/nftables OpenWrt install. We request it explicitly now to make life easier in case people would like to try ss-rules/iptables on firewall4/nftables enabled OpenWrt system Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'net')
-rw-r--r--net/shadowsocks-libev/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/net/shadowsocks-libev/Makefile b/net/shadowsocks-libev/Makefile
index 75c6b3ccd..1da8b2a9b 100644
--- a/net/shadowsocks-libev/Makefile
+++ b/net/shadowsocks-libev/Makefile
@@ -14,7 +14,7 @@ include $(TOPDIR)/rules.mk
#
PKG_NAME:=shadowsocks-libev
PKG_VERSION:=3.3.5
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/shadowsocks/shadowsocks-libev/releases/download/v$(PKG_VERSION)
@@ -89,7 +89,7 @@ define Package/shadowsocks-libev-ss-rules
SUBMENU:=Web Servers/Proxies
TITLE:=shadowsocks-libev ss-rules
URL:=https://github.com/shadowsocks/shadowsocks-libev
- DEPENDS:=+ip +ipset +iptables-mod-tproxy +resolveip +shadowsocks-libev-ss-redir +shadowsocks-libev-config
+ DEPENDS:=+ip +ipset +iptables-mod-tproxy +kmod-ipt-nat +resolveip +shadowsocks-libev-ss-redir +shadowsocks-libev-config
endef
define Package/shadowsocks-libev-ss-rules/install