aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorchamptar <champetier.etienne@gmail.com>2014-10-30 18:11:11 +0100
committerchamptar <champetier.etienne@gmail.com>2014-10-30 18:11:11 +0100
commitdec433d68aab6e24c245c0ea5b82137660c53b46 (patch)
treede1766bd39bd7d22e408f5d743b2bed82d0f0f1b /net
parent6f80d6fa6899372ca23d87840c74b57bae912fad (diff)
parentd16d96f52d2d2de5af7bdd820f3a6605f414a614 (diff)
Merge pull request #485 from commodo/ovs-build-fix
openvswitch: fix build for gcc versions below 4.9
Diffstat (limited to 'net')
-rw-r--r--net/openvswitch/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/net/openvswitch/Makefile b/net/openvswitch/Makefile
index 627b1ec86..669df8a3c 100644
--- a/net/openvswitch/Makefile
+++ b/net/openvswitch/Makefile
@@ -119,6 +119,11 @@ define Build/Configure
$(call Build/Configure/Default,$(CONFIGURE_ARGS))
endef
+KCFLAGS=
+ifeq ($(CONFIG_GCC_VERSION_4_9),y)
+KCFLAGS:=-Wno-error=date-time
+endif
+
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
$(TARGET_CONFIGURE_OPTS) \
@@ -131,7 +136,7 @@ define Build/Compile
ARCH="$(LINUX_KARCH)" \
SUBDIRS="$(PKG_BUILD_DIR)/datapath/linux" \
PATH="$(TARGET_PATH)" \
- KCFLAGS="-Wno-error=date-time" \
+ KCFLAGS="$(KCFLAGS)" \
KCC="$(KERNEL_CC)"
endef