aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorMichael Heimpold <mhei@heimpold.de>2021-02-20 21:19:53 +0100
committerGitHub <noreply@github.com>2021-02-20 21:19:53 +0100
commitd651082447b4392399a40ea1ae11d0bce4bfe83a (patch)
treeee8ae69b454eb82fe7ede4e48dc0a49274eff378 /net
parent3a1798155c64a80fb2430f3db6c8ca51cde580da (diff)
parentf2877e81f6facba47513107651a5fef207c421d2 (diff)
Merge pull request #14741 from mhei/openconnect-iconv-intl
openconnect: fix dependencies to iconv/intl (fixes #14734)
Diffstat (limited to 'net')
-rw-r--r--net/openconnect/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/net/openconnect/Makefile b/net/openconnect/Makefile
index 59e81f77a..14febb84e 100644
--- a/net/openconnect/Makefile
+++ b/net/openconnect/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=openconnect
PKG_VERSION:=8.10
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=ftp://ftp.infradead.org/pub/openconnect/
@@ -26,6 +26,7 @@ PKG_CONFIG_DEPENDS:= \
PKG_USE_MIPS16:=0
include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/nls.mk
define Package/openconnect/config
source "$(SOURCE)/Config.in"
@@ -34,7 +35,7 @@ endef
define Package/openconnect
SECTION:=net
CATEGORY:=Network
- DEPENDS:=+libxml2 +kmod-tun +resolveip +vpnc-scripts +OPENCONNECT_OPENSSL:libopenssl +OPENCONNECT_OPENSSL:p11-kit +OPENCONNECT_OPENSSL:libp11 +OPENCONNECT_GNUTLS:libgnutls +OPENCONNECT_GNUTLS:libtasn1 +OPENCONNECT_STOKEN:libstoken
+ DEPENDS:=+libxml2 +kmod-tun +resolveip +vpnc-scripts +OPENCONNECT_OPENSSL:libopenssl +OPENCONNECT_OPENSSL:p11-kit +OPENCONNECT_OPENSSL:libp11 +OPENCONNECT_GNUTLS:libgnutls +OPENCONNECT_GNUTLS:libtasn1 +OPENCONNECT_STOKEN:libstoken $(ICONV_DEPENDS) $(INTL_DEPENDS)
TITLE:=OpenConnect VPN client (Cisco AnyConnect and Juniper/Pulse compatible)
MAINTAINER:=Nikos Mavrogiannopoulos <n.mavrogiannopoulos@gmail.com>
URL:=https://www.infradead.org/openconnect/
@@ -55,6 +56,8 @@ endef
CONFIGURE_ARGS += \
--disable-shared \
+ --with-libiconv-prefix=$(ICONV_PREFIX) \
+ --with-libintl-prefix=$(INTL_PREFIX) \
--with-vpnc-script=/lib/netifd/vpnc-script \
--without-libpcsclite \
--without-stoken \