aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorTony Ambardar <itugrok@yahoo.com>2018-08-07 02:03:08 -0700
committerguidosarducci <guidosarducci@users.noreply.github.com>2018-09-23 21:55:03 -0700
commitd5b0c46ece4bc494843ff99758704122684b8641 (patch)
tree655b7540f8e58fc0322be803da96e447ecff613b /net
parent222b9f50f3c2e3087cc23fa1610b75b73ebfda69 (diff)
stubby: rearrange Makefile for clarity
Signed-off-by: Tony Ambardar <itugrok@yahoo.com>
Diffstat (limited to 'net')
-rw-r--r--net/stubby/Makefile21
1 files changed, 10 insertions, 11 deletions
diff --git a/net/stubby/Makefile b/net/stubby/Makefile
index 3f3df9c12..6ff93162d 100644
--- a/net/stubby/Makefile
+++ b/net/stubby/Makefile
@@ -29,12 +29,6 @@ define Package/stubby/Default
URL:=https://dnsprivacy.org/wiki/display/DP/DNS+Privacy+Daemon+-+Stubby
endef
-define Package/stubby/description
- This package contains the Stubby daemon (which utilizes the getdns library).
-
- See https://github.com/openwrt/packages/blob/master/net/stubby/files/README.md for more details.
-endef
-
define Package/stubby
$(call Package/stubby/Default)
SECTION:=net
@@ -45,6 +39,16 @@ define Package/stubby
DEPENDS:= +libyaml +getdns +ca-certificates
endef
+define Package/stubby/description
+ This package contains the Stubby daemon (which utilizes the getdns library).
+
+ See https://github.com/openwrt/packages/blob/master/net/stubby/files/README.md for more details.
+endef
+
+define Package/stubby/conffiles
+ /etc/stubby/stubby.yml
+endef
+
define Package/stubby/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/stubby $(1)/usr/sbin/stubby
@@ -55,9 +59,4 @@ define Package/stubby/install
$(INSTALL_DATA) ./files/stubby.yml $(1)/etc/stubby/stubby.yml
endef
-
-define Package/stubby/conffiles
- /etc/stubby/stubby.yml
-endef
-
$(eval $(call BuildPackage,stubby))