aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorToke Høiland-Jørgensen <toke@toke.dk>2022-12-17 22:17:26 +0100
committerToke Høiland-Jørgensen <toke@toke.dk>2022-12-17 23:43:05 +0100
commitd51c948c1f65b73a603ec60be699a1dc038935c8 (patch)
treec951885aaed365c92becb6b2b620aef628225274 /net
parent6818f1e521236f1d21478b1d693db785129bd7cf (diff)
flent: Integrate flent-tools into the flent package
Now that we're packaging flent itself, there's no reason to have a completely separate flent-tools package. So integrate the flent-tools package specification into the main flent package so it's always kept in sync. Also add a dependency from flent itself on flent-tools, as the shell versions of those utilities that Flent uses when running tests doesn't work on the busybox shell included with openwrt. Signed-off-by: Toke Høiland-Jørgensen <toke@toke.dk>
Diffstat (limited to 'net')
-rw-r--r--net/flent/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/net/flent/Makefile b/net/flent/Makefile
index 15180f251..276ff07da 100644
--- a/net/flent/Makefile
+++ b/net/flent/Makefile
@@ -13,6 +13,7 @@ PKG_LICENSE_FILES:=LICENSE
include ../../lang/python/pypi.mk
include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/nls.mk
include ../../lang/python/python3-package.mk
define Package/flent
@@ -27,6 +28,7 @@ define Package/flent
+python3-logging \
+python3-distutils \
+python3-defusedxml \
+ +flent-tools \
+netperf \
+fping
endef
@@ -36,6 +38,40 @@ define Package/flent/description
netperf/iperf/ping instances and aggregate the results.
endef
+
+define Package/flent-tools
+ SECTION:=utils
+ CATEGORY:=Utilities
+ TITLE:=Helper programs for the Flent test tool
+ URL:=https://flent.org
+ DEPENDS+=+librt +coreutils-sleep +coreutils-date
+endef
+
+define Package/flent-tools/description
+ This builds the C helper programs for gathering data for
+ the Flent network testing tool. These tools are needed for
+ gathering data when a Bash shell is not available (and also
+ perform better than the shell equivalents).
+endef
+
+define Build/Compile/flent-tools
+ $(MAKE) -C $(PKG_BUILD_DIR)/misc \
+ CC="$(TARGET_CC)" \
+ CFLAGS="$(TARGET_CFLAGS) -std=gnu99"
+endef
+
+define Package/flent-tools/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/misc/tc_iterate $(1)/usr/sbin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/misc/wifistats_iterate $(1)/usr/sbin/
+endef
+
+define Build/Compile
+ $(call Py3Build/Compile)
+ $(call Build/Compile/flent-tools)
+endef
+
$(eval $(call Py3Package,flent))
$(eval $(call BuildPackage,flent))
$(eval $(call BuildPackage,flent-src))
+$(eval $(call BuildPackage,flent-tools))