aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2015-05-26 08:50:51 +0200
committerSteven Barth <steven@midlink.org>2015-05-26 08:50:51 +0200
commitd2670b43f2a88978b7fa53d0115a0410c66c9d71 (patch)
tree456b969b8b8d065f77ec6967f691227f7381f607 /net
parentccd9752fb68c7ce3d6f70896a717f64a882fd62c (diff)
parent65fb23d51589b42d9155bab73b0544b5b182a96c (diff)
Merge pull request #1298 from chris5560/master
radicale: fixed hotplug and init script
Diffstat (limited to 'net')
-rw-r--r--net/radicale/Makefile4
-rw-r--r--net/radicale/files/radicale.config2
-rw-r--r--net/radicale/files/radicale.hotplug2
-rwxr-xr-xnet/radicale/files/radicale.init2
4 files changed, 4 insertions, 6 deletions
diff --git a/net/radicale/Makefile b/net/radicale/Makefile
index 329ab68f0..f604a9fdf 100644
--- a/net/radicale/Makefile
+++ b/net/radicale/Makefile
@@ -8,8 +8,8 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=radicale
PKG_VERSION:=0.10
-PKG_RELEASE:=1
-PKG_MAINTAINER:=Christian Schoenebeck <chris5560@web.de>
+PKG_RELEASE:=2
+PKG_MAINTAINER:=Christian Schoenebeck <christian.schoenebeck@gmail.com>
PKG_LICENSE:=GPL-3.0
PKG_LICENSE_FILES:=COPYING
diff --git a/net/radicale/files/radicale.config b/net/radicale/files/radicale.config
index ea10bc9f4..58148f823 100644
--- a/net/radicale/files/radicale.config
+++ b/net/radicale/files/radicale.config
@@ -71,7 +71,6 @@ config setting 'auth'
# Value: None | htpasswd | IMAP | LDAP | PAM | courier | http | remote_user | custom
# Default: None
# if setting 'htpasswd' the file /etc/radicale/users is used (hardcoded)
-# option type 'htpasswd'
# Htpasswd encryption method
# Value: plain | sha1 | ssha | crypt
@@ -98,7 +97,6 @@ config setting 'rights'
# Value: None | authenticated | owner_only | owner_write | from_file | custom
# Default: None
# if setting 'from_file' the file /etc/radicale/rights is used (hardcoded)
-# option type 'from_file'
# Custom rights handler
# option custom_handler ''
diff --git a/net/radicale/files/radicale.hotplug b/net/radicale/files/radicale.hotplug
index 634ad2efa..3b9141986 100644
--- a/net/radicale/files/radicale.hotplug
+++ b/net/radicale/files/radicale.hotplug
@@ -3,7 +3,7 @@
# only (re-)start on ifup
[ "$ACTION" = "ifup" ] || exit 0
-_PID=$(ps | grep '[p]ython.*[r]adicale' 2>/dev/null | awk '{print \$1}')
+_PID=$(ps | grep '[p]ython.*[r]adicale' 2>/dev/null | awk '{print $1}')
kill -1 $_PID 2>/dev/null
if [ $? -eq 0 ]; then
# only restart if already running
diff --git a/net/radicale/files/radicale.init b/net/radicale/files/radicale.init
index bb35a18a0..991ca5051 100755
--- a/net/radicale/files/radicale.init
+++ b/net/radicale/files/radicale.init
@@ -208,7 +208,7 @@ stop() {
local _PID=$(eval "$PGREP")
[ -z "$_PID" ] && return 0 # not running
kill -15 $_PID 2>/dev/null
- sleep 1 # give time to shutdown
+ sleep 3 # give time to shutdown
local _tmp=$(eval "$PGREP")
if [ -z "$_tmp" ]; then
logger -p user.notice -t "radicale[$_PID]" "Service shutdown successfully"