aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorkrant <aleksey.vasilenko@gmail.com>2024-02-22 21:03:05 +0200
committerRosen Penev <rosenp@gmail.com>2024-02-22 15:22:03 -0800
commitd1e721720f95b765820c33f68964e0ed4487fb5e (patch)
tree6089d86ecd8545efea12dc43a498334ca4fd291b /net
parentecbe8ca508828eb6bd1205b3b9d5bef43c130948 (diff)
boinc: update to 7.24.3
- Use local tarball - Remove upstreamed and refresh remaining patches Signed-off-by: krant <aleksey.vasilenko@gmail.com>
Diffstat (limited to 'net')
-rw-r--r--net/boinc/Makefile13
-rw-r--r--net/boinc/patches/000-100-backport-reset-cflags-before-call.patch45
-rw-r--r--net/boinc/patches/001-avoidExtraDependencies4
-rw-r--r--net/boinc/patches/002-hosttypeRespected6
-rw-r--r--net/boinc/patches/003-update-to-openssl-3.0.0.patch34
5 files changed, 11 insertions, 91 deletions
diff --git a/net/boinc/Makefile b/net/boinc/Makefile
index 3714574e0..53d1e074c 100644
--- a/net/boinc/Makefile
+++ b/net/boinc/Makefile
@@ -6,15 +6,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=boinc
-PKG_VERSION:=7.16.16
+PKG_VERSION:=7.24.3
PKG_VERSION_SHORT:=$(shell echo $(PKG_VERSION)| cut -f1,2 -d.)
-PKG_RELEASE:=3
+PKG_RELEASE:=1
-PKG_SOURCE_DATE:=2020-02-25
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://codeload.github.com/BOINC/boinc/tar.gz/client_release/$(PKG_VERSION_SHORT)/$(PKG_VERSION)?
-PKG_HASH:=0d5656a9f8ed1048936a5764270848b892d63f27bdb863d0ace447f1eaae6002
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-client_release-$(PKG_VERSION_SHORT)-$(PKG_VERSION)
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=https://github.com/BOINC/boinc
+PKG_SOURCE_VERSION:=client_release/$(PKG_VERSION_SHORT)/$(PKG_VERSION)
+PKG_MIRROR_HASH:=c13c496c3d7127c410b1628afecacd6ce46648af01b1549dc79d418159cf69ad
PKG_MAINTAINER:=Christian Dreihsig <christian.dreihsig@t-online.de>, Steffen Moeller <moeller@debian.org>
PKG_LICENSE:=GPL-3.0-or-later
diff --git a/net/boinc/patches/000-100-backport-reset-cflags-before-call.patch b/net/boinc/patches/000-100-backport-reset-cflags-before-call.patch
deleted file mode 100644
index 5f4858209..000000000
--- a/net/boinc/patches/000-100-backport-reset-cflags-before-call.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-From 3f6fc35cc28387e327cb6f47feb00061ed17b84c
-From: Mamoru TASAKA <mtasaka@fedoraproject.org>
-Date: Sat, 30 Apr 2022 13:32:34 +0900
-Subject: [PATCH] configure.ac: reset compiler flags before calling
- AC_CHECK_DECLS
-
-With autoconf 2.71, [AC_CHECK_DECLS] calls new internal macro
-[_AC_UNDECLARED_BUILTIN], which raises error with unknown compiler
-flag. On non-x86 archs, -mavx or so is not recognized, so configure
-fails on such architecture.
-
-To fix this, reset vector related compiler flags before calling
-AC_CHECK_DECLS.
-
-*OPENWRT EDIT: typo "sse_flags"
----
- configure.ac | 16 ++++++++++++----
- 1 file changed, 12 insertions(+), 4 deletions(-)
-
---- a/configure.ac
-+++ b/configure.ac
-@@ -674,11 +674,19 @@ AC_CHECK_HEADERS([sys/types.h sys/un.h a
-
- save_cxxflags="${CXXFLAGS}"
- save_cppflags="${CPPFLAGS}"
--CXXFLAGS="${CXXFLAGS} -msse3"
--CPPFLAGS="${CPPFLAGS} -msse3"
-+sse3_flags="-msse3"
-+avx_flags="-mavx"
-+CXXFLAGS="${save_cxxflags} ${sse3_flags}"
-+CPPFLAGS="${save_cppflags} ${sse3_flags}"
-+AC_LINK_IFELSE([AC_LANG_PROGRAM([],)], [], [sse3_flags=""])
-+CXXFLAGS="${save_cxxflags} ${avx_flags}"
-+CPPFLAGS="${save_cppflags} ${avx_flags}"
-+AC_LINK_IFELSE([AC_LANG_PROGRAM([],)], [], [avx_flags=""])
-+CXXFLAGS="${save_cxxflags} ${sse3_flags}"
-+CXXFLAGS="${save_cxxflags} ${sse3_flags}"
- AC_CHECK_HEADERS([intrin.h x86intrin.h pmmintrin.h xmmintrin.h emmintrin.h])
--CXXFLAGS="${save_cxxflags} -mavx"
--CPPFLAGS="${save_cppflags} -mavx"
-+CXXFLAGS="${save_cxxflags} ${avx_flags}"
-+CPPFLAGS="${save_cppflags} ${avx_flags}"
- AC_CHECK_HEADERS([immintrin.h avxintrin.h])
-
- AC_CHECK_DECLS([_xgetbv, xgetbv, __xgetbv, cpuid, _cpuid, __cpuid],
diff --git a/net/boinc/patches/001-avoidExtraDependencies b/net/boinc/patches/001-avoidExtraDependencies
index ca46bef58..680028488 100644
--- a/net/boinc/patches/001-avoidExtraDependencies
+++ b/net/boinc/patches/001-avoidExtraDependencies
@@ -1,6 +1,6 @@
--- a/configure.ac
+++ b/configure.ac
-@@ -502,8 +502,10 @@ SAH_CHECK_LIB([dl], [dlopen],
+@@ -543,8 +543,10 @@ SAH_CHECK_LIB([dl], [dlopen],
[BOINC_EXTRA_LIBS="${BOINC_EXTRA_LIBS} ${sah_lib_last}"])
SAH_CHECK_LIB([nsl], [gethostbyname],
[BOINC_EXTRA_LIBS="${BOINC_EXTRA_LIBS} ${sah_lib_last}"])
@@ -10,4 +10,4 @@
+fi
SAH_CHECK_LIB([socket], [bind],
[BOINC_EXTRA_LIBS="${BOINC_EXTRA_LIBS} ${sah_lib_last}"])
- SAH_CHECK_LIB([z], [gzopen],
+ SAH_CHECK_LIB([z], [gzopen], [
diff --git a/net/boinc/patches/002-hosttypeRespected b/net/boinc/patches/002-hosttypeRespected
index 35a3fb4ea..eeaeecde9 100644
--- a/net/boinc/patches/002-hosttypeRespected
+++ b/net/boinc/patches/002-hosttypeRespected
@@ -1,6 +1,6 @@
--- a/client/cs_platforms.cpp
+++ b/client/cs_platforms.cpp
-@@ -76,6 +76,21 @@ void CLIENT_STATE::add_platform(const ch
+@@ -171,6 +171,21 @@ int launch_child_process_to_detect_emula
//
void CLIENT_STATE::detect_platforms() {
@@ -22,7 +22,7 @@
#if defined(_WIN32) && !defined(__CYGWIN32__)
#if defined(_WIN64) && defined(_M_X64)
add_platform("windows_x86_64");
-@@ -210,15 +225,6 @@ void CLIENT_STATE::detect_platforms() {
+@@ -306,15 +321,6 @@ void CLIENT_STATE::detect_platforms() {
add_platform("i686-pc-linux-gnu");
}
@@ -38,7 +38,7 @@
#elif defined(sun)
// Check if we can run 64-bit binaries...
// this assumes there isn't a 64-bit only solaris. (Every 64-bit solaris can run 32 bit binaries)
-@@ -294,6 +300,8 @@ void CLIENT_STATE::detect_platforms() {
+@@ -390,6 +396,8 @@ void CLIENT_STATE::detect_platforms() {
#endif
#endif
diff --git a/net/boinc/patches/003-update-to-openssl-3.0.0.patch b/net/boinc/patches/003-update-to-openssl-3.0.0.patch
deleted file mode 100644
index 75fab9058..000000000
--- a/net/boinc/patches/003-update-to-openssl-3.0.0.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From 689dc20ede9768377d4032ff8c70b58269c8dc9c Mon Sep 17 00:00:00 2001
-From: Charlie Fenton <charlief@example.com>
-Date: Mon, 18 Oct 2021 01:43:08 -0700
-Subject: [PATCH] Mac: update dependent libraries to latest: c-ares-1.17.2,
- curl-7.79.1, freetype-2.11.0, openssl-3.0.0 Previously updated to
- wxWidgets-3.1.5. FTGL version ftgl-2.1.3~rc5 is still the current version.
-
----
-cotequeiroz: Trimming original commit to lib/crypt.cpp only
-
- lib/crypt.cpp | 7 +-
-
---- a/lib/crypt.cpp
-+++ b/lib/crypt.cpp
-@@ -1,6 +1,6 @@
- // This file is part of BOINC.
- // http://boinc.berkeley.edu
--// Copyright (C) 2008 University of California
-+// Copyright (C) 2021 University of California
- //
- // BOINC is free software; you can redistribute it and/or modify it
- // under the terms of the GNU Lesser General Public License
-@@ -670,7 +670,10 @@ int check_validity_of_cert(
- }
- #ifdef HAVE_OPAQUE_RSA_DSA_DH
- RSA *rsa;
-- rsa = EVP_PKEY_get0_RSA(pubKey);
-+ // CAUTION: In OpenSSL 3.0.0, EVP_PKEY_get0_RSA() now returns a
-+ // pointer of type "const struct rsa_st*" to an immutable value.
-+ // Do not try to modify the contents of the returned struct.
-+ rsa = (rsa_st*)EVP_PKEY_get0_RSA(pubKey);
- if (!RSA_blinding_on(rsa, c)) {
- #else
- if (!RSA_blinding_on(pubKey->pkey.rsa, c)) {