aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-08-07 11:57:29 -0700
committerGitHub <noreply@github.com>2020-08-07 11:57:29 -0700
commitd179b11410b0f7f0cac8ec49eaf3abd19aff357b (patch)
treec784fd4b778cf8d9ef759f63c873e3dbe93fbeff /net
parent61b3532fe4e6fb750fdee509aa9f7bc786cd730e (diff)
parentf45ce492fa03bc07febcb3611fbd0ac93d869433 (diff)
Merge pull request #13029 from neheb/boinc
boinc: fix compilation without deprecated OpenSSL APIs
Diffstat (limited to 'net')
-rw-r--r--net/boinc/Makefile2
-rw-r--r--net/boinc/patches/010-openssl.patch31
2 files changed, 32 insertions, 1 deletions
diff --git a/net/boinc/Makefile b/net/boinc/Makefile
index fb80e9aa5..88160affb 100644
--- a/net/boinc/Makefile
+++ b/net/boinc/Makefile
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=boinc
PKG_VERSION:=7.16.6
PKG_VERSION_SHORT:=$(shell echo $(PKG_VERSION)| cut -f1,2 -d.)
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_DATE:=2020-02-25
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
diff --git a/net/boinc/patches/010-openssl.patch b/net/boinc/patches/010-openssl.patch
new file mode 100644
index 000000000..afe68d6c0
--- /dev/null
+++ b/net/boinc/patches/010-openssl.patch
@@ -0,0 +1,31 @@
+--- a/lib/crypt.cpp
++++ b/lib/crypt.cpp
+@@ -44,6 +44,7 @@
+ #include <openssl/engine.h>
+ #include <openssl/err.h>
+ #include <openssl/rsa.h>
++#include <openssl/bn.h>
+
+ #ifdef _USING_FCGI_
+ #include "boinc_fcgi.h"
+@@ -720,8 +721,10 @@ char *check_validity(
+ int rbytes;
+ unsigned char md5_md[MD5_DIGEST_LENGTH], rbuf[2048];
+
++#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(HAVE_LIBRESSL)
+ SSL_load_error_strings();
+ SSL_library_init();
++#endif
+
+ if (!is_file(origFile)) {
+ return NULL;
+@@ -772,7 +775,9 @@ int cert_verify_file(
+ fflush(stdout);
+ return false;
+ }
++#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(HAVE_LIBRESSL)
+ SSL_library_init();
++#endif
+ if (!is_file(origFile)) return false;
+ FILE* of = boinc_fopen(origFile, "r");
+ if (!of) return false;