aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorAlexandru Ardelean <aa@ocedo.com>2014-09-18 17:13:13 +0300
committerAlexandru Ardelean <ardeleanalex@gmail.com>2014-10-17 18:03:29 +0300
commitcfa1b5e17bf46271caed831cf3096a54e9b645d5 (patch)
tree4fd14cabcd95b44adc1da817de8454fa20ed39e2 /net
parent00cfd790067037df36374077f96217b79bf754f9 (diff)
openvswitch: add openvswitch-ipsesc package back
Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Diffstat (limited to 'net')
-rw-r--r--net/openvswitch/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/net/openvswitch/Makefile b/net/openvswitch/Makefile
index bf4873704..bb5b268dd 100644
--- a/net/openvswitch/Makefile
+++ b/net/openvswitch/Makefile
@@ -67,6 +67,17 @@ define Package/openvswitch-python/description
Provides bindings and libraries for using Python to manipulate/work with Open vSwitch.
endef
+define Package/openvswitch-ipsec
+ $(call Package/openvswitch/Default)
+ TITLE:=Open vSwitch Userspace Package
+ DEPENDS:=@PACKAGE_openvswitch +PACKAGE_openvswitch:openvswitch-python
+endef
+
+define Package/openvswitch-ipsec/description
+ The ovs-monitor-ipsec script provides support for encrypting GRE tunnels with
+ IPsec.
+endef
+
define Package/openvswitch-benchmark
$(call Package/openvswitch/Default)
TITLE:=Open vSwitch Userspace Package
@@ -157,6 +168,11 @@ define Package/openvswitch-python/install
$(CP) $(PKG_BUILD_DIR)/python/ovs/ $(1)/usr/lib/python$(PYTHON_VERSION)/
endef
+define Package/openvswitch-ipsec/install
+ $(INSTALL_DIR) $(1)/usr/sbin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/debian/ovs-monitor-ipsec $(1)/usr/sbin/
+endef
+
define Package/openvswitch-benchmark/install
$(INSTALL_DIR) $(1)/usr/bin/
$(INSTALL_BIN) $(PKG_BUILD_DIR)/utilities/.libs/ovs-benchmark $(1)/usr/bin/
@@ -169,6 +185,7 @@ endef
$(eval $(call BuildPackage,openvswitch))
$(eval $(call BuildPackage,openvswitch-python))
+$(eval $(call BuildPackage,openvswitch-ipsec))
$(eval $(call BuildPackage,openvswitch-benchmark))
$(eval $(call KernelPackage,openvswitch))