aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorJonas Jelonek <jelonek.jonas@gmail.com>2023-07-06 15:14:45 +0200
committerJonas Jelonek <jelonek.jonas@gmail.com>2023-09-01 08:37:44 +0200
commitcd548cea542a182f5e44a8f2666e3fca5fa7398a (patch)
tree963bf29c64f2994c8b9d3e3d1b58723e118c63c4 /net
parent3b8921d1aed3c183cc02f57fe7809af4d20ecf18 (diff)
croc: new package
croc is a tool written in Go for sending files from one device to another over the internet using a relay. It runs on multiple platforms, provides end-to-end encryption and works without port forwarding and fixed IP/DynDNS. Signed-off-by: Jonas Jelonek <jelonek.jonas@gmail.com>
Diffstat (limited to 'net')
-rw-r--r--net/croc/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/net/croc/Makefile b/net/croc/Makefile
new file mode 100644
index 000000000..eab3c8e70
--- /dev/null
+++ b/net/croc/Makefile
@@ -0,0 +1,45 @@
+# SPDX-License-Identifier: GPL-2.0-only
+#
+# Copyright (C) 2023 Jonas Jelonek
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=croc
+PKG_VERSION:=9.6.5
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://codeload.github.com/schollz/croc/tar.gz/v$(PKG_VERSION)?
+PKG_HASH:=2d3ba7bae3c49e3870e2f8523c6be00e92fe6e46828269a8cea34d4034102cad
+
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+PKG_MAINTAINER:=Jonas Jelonek <jelonek.jonas@gmail.com>
+
+PKG_BUILD_DEPENDS:=golang/host
+PKG_BUILD_PARALLEL:=1
+PKG_BUILD_FLAGS:=no-mips16
+
+GO_PKG:=github.com/schollz/croc/v9
+GO_PKG_BUILD_PKG:=$(GO_PKG)
+GO_PKG_LDFLAGS_X:=$(GO_PKG)/src/cli.Version=v$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+include ../../lang/golang/golang-package.mk
+
+define Package/croc
+ SECTION:=net
+ CATEGORY:=Network
+ SUBMENU:=File Transfer
+ TITLE:=Easily and securely send things from one computer to another
+ URL:=https://github.com/schollz/croc
+ DEPENDS:=$(GO_ARCH_DEPENDS)
+endef
+
+define Package/croc/description
+ croc is a tool that allows any two computers to simply and securely
+ transfer files and folders by using a relay.
+endef
+
+$(eval $(call GoBinPackage,croc))
+$(eval $(call BuildPackage,croc))