aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorPhilip Prindeville <philipp@redfish-solutions.com>2021-06-17 18:53:08 -0600
committerPhilip Prindeville <philipp@redfish-solutions.com>2021-06-17 18:53:08 -0600
commitcac7608211c1601f854a12dc9ddc9ebdf49e780b (patch)
tree518f00fdf45b0fb25df70d52957434304ade0210 /net
parent0c16840e26ed0a8a808f22a1f5f4dbd265e0a903 (diff)
strongswan: use correct directory for CA's
Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
Diffstat (limited to 'net')
-rw-r--r--net/strongswan/Makefile2
-rwxr-xr-xnet/strongswan/files/gencerts.sh2
2 files changed, 2 insertions, 2 deletions
diff --git a/net/strongswan/Makefile b/net/strongswan/Makefile
index 42d7ec218..70f1e8e6f 100644
--- a/net/strongswan/Makefile
+++ b/net/strongswan/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=strongswan
PKG_VERSION:=5.9.2
-PKG_RELEASE:=9
+PKG_RELEASE:=10
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://download.strongswan.org/ https://download2.strongswan.org/
diff --git a/net/strongswan/files/gencerts.sh b/net/strongswan/files/gencerts.sh
index abd167b39..8df5606b0 100755
--- a/net/strongswan/files/gencerts.sh
+++ b/net/strongswan/files/gencerts.sh
@@ -72,7 +72,7 @@ genca()
pki --self --ca --lifetime "$CADAYS" --in "$SWANCTL_DIR/private/$SHORT_DOMAIN.key" --type "$keytype" \
--dn "$ROOTDN" --outform pem > "$SWANCTL_DIR/x509ca/$SHORT_DOMAIN.crt"
- chmod 0444 "$SWANCTL_DIR/cacerts/$SHORT_DOMAIN.crt"
+ chmod 0444 "$SWANCTL_DIR/x509ca/$SHORT_DOMAIN.crt"
}
genclientkey()