aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorLucian Cristian <lucian.cristian@gmail.com>2020-05-10 00:03:55 +0300
committerLucian Cristian <lucian.cristian@gmail.com>2020-05-10 00:03:55 +0300
commitc825364c1d3c45d1dac321ec1a8209f44da75d8d (patch)
tree7f7d065f51dca374abf1d14bc4a35f3bdcdb7319 /net
parent0206a87146fef2b20d18187832935f63641f5c9b (diff)
Netopeer2: update Netopeer2 and dependencies to master
libnetconf2 to 1.1.24 libyang to 1.0.167 sysrepo to 1.4.58 Signed-off-by: Lucian Cristian <lucian.cristian@gmail.com>
Diffstat (limited to 'net')
-rw-r--r--net/Netopeer2/Makefile51
-rw-r--r--net/Netopeer2/files/netopeer2-keystored-keygen.default2
-rw-r--r--net/Netopeer2/files/netopeer2-keystored.default2
-rw-r--r--net/Netopeer2/files/netopeer2-server.default19
-rw-r--r--net/Netopeer2/patches/001-fix-for-cmake-build.patch68
-rw-r--r--net/Netopeer2/patches/001-openss_1.1_support.patch11
-rw-r--r--net/Netopeer2/patches/002-fix-keystored-cross-compile.patch16
-rw-r--r--net/sysrepo/Makefile4
8 files changed, 44 insertions, 129 deletions
diff --git a/net/Netopeer2/Makefile b/net/Netopeer2/Makefile
index db6fd8d46..a26ac4e4c 100644
--- a/net/Netopeer2/Makefile
+++ b/net/Netopeer2/Makefile
@@ -10,12 +10,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=Netopeer2
-PKG_VERSION:=0.7-r2
+PKG_VERSION:=1.1.27
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/CESNET/Netopeer2/tar.gz/v$(PKG_VERSION)?
-PKG_HASH:=59688271be4fecbbee671fc7eb3dc0538b13b4baab53e923e26eaeb33e6f7ec0
+PKG_HASH:=e3914aae78d19f445a37ef37408f7ce209ebf0b05deb412b1bc56a021448885f
PKG_MAINTAINER:=Mislav Novakovic <mislav.novakovic@sartura.hr>
PKG_LICENSE:=BSD-3-Clause
@@ -65,26 +65,30 @@ define Package/netopeer2/description
endef
CMAKE_OPTIONS += \
- -DKEYSTORED_KEYS_DIR:STRING=/etc/keystored/keys \
- -DENABLE_CONFIGURATION:BOOL=OFF \
- -DMODEL_INSTALL:BOOL=OFF \
- -DSSH_KEY_INSTALL:BOOL=OFF
+ -DGENERATE_HOSTKEY:BOOL=OFF \
+ -DINSTALL_MODULES:BOOL=OFF \
+ -DCMAKE_BUILD_TYPE=release
+
+#-DKEYSTORED_KEYS_DIR:STRING=/etc/keystored/keys \
define Package/netopeer2-server/install
- $(INSTALL_DIR) $(1)/bin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/server/netopeer2-server $(1)/bin/
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/netopeer2-server $(1)/usr/bin/
$(INSTALL_DIR) $(1)/etc/sysrepo/yang
- $(INSTALL_DATA) $(PKG_BUILD_DIR)/modules/ietf-ssh-server.yang $(1)/etc/sysrepo/yang/ietf-ssh-server@2016-11-02.yang
- $(INSTALL_DATA) $(PKG_BUILD_DIR)/modules/ietf-tls-server.yang $(1)/etc/sysrepo/yang/ietf-tls-server@2016-11-02.yang
- $(INSTALL_DATA) $(PKG_BUILD_DIR)/modules/iana-crypt-hash.yang $(1)/etc/sysrepo/yang/iana-crypt-hash@2014-08-06.yang
- $(INSTALL_DATA) $(PKG_BUILD_DIR)/modules/ietf-x509-cert-to-name.yang $(1)/etc/sysrepo/yang/ietf-x509-cert-to-name@2014-12-10.yang
- $(INSTALL_DATA) $(PKG_BUILD_DIR)/modules/ietf-netconf-server.yang $(1)/etc/sysrepo/yang/ietf-netconf-server@2016-11-02.yang
- $(INSTALL_DATA) $(PKG_BUILD_DIR)/modules/ietf-netconf-monitoring.yang $(1)/etc/sysrepo/yang/ietf-netconf-monitoring@2010-10-04.yang
- $(INSTALL_DATA) $(PKG_BUILD_DIR)/modules/ietf-netconf-with-defaults.yang $(1)/etc/sysrepo/yang/ietf-netconf-with-defaults@2011-06-01.yang
- $(INSTALL_DATA) $(PKG_BUILD_DIR)/modules/ietf-system.yang $(1)/etc/sysrepo/yang/ietf-system@2014-08-06.yang
- $(INSTALL_DATA) $(PKG_BUILD_DIR)/modules/ietf-datastores.yang $(1)/etc/sysrepo/yang/ietf-datastores@2017-08-17.yang
- $(INSTALL_DATA) $(PKG_BUILD_DIR)/modules/ietf-yang-library.yang $(1)/etc/sysrepo/yang/ietf-yang-library@2018-01-17.yang
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/modules/ietf-ssh-server@2019-07-02.yang $(1)/etc/sysrepo/yang/
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/modules/ietf-tls-server@2019-07-02.yang $(1)/etc/sysrepo/yang/
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/modules/iana-crypt-hash@2014-08-06.yang $(1)/etc/sysrepo/yang/
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/modules/ietf-x509-cert-to-name@2014-12-10.yang $(1)/etc/sysrepo/yang/
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/modules/ietf-netconf-server@2019-07-02.yang $(1)/etc/sysrepo/yang/
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/modules/ietf-netconf-monitoring@2010-10-04.yang $(1)/etc/sysrepo/yang/
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/modules/ietf-netconf-acm@2018-02-14.yang $(1)/etc/sysrepo/yang/
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/modules/ietf-netconf-nmda@2019-01-07.yang $(1)/etc/sysrepo/yang/
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/modules/ietf-netconf@2013-09-29.yang $(1)/etc/sysrepo/yang/
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/modules/ietf-datastores@2017-08-17.yang $(1)/etc/sysrepo/yang/
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/modules/ietf-crypto-types@2019-07-02.yang $(1)/etc/sysrepo/yang/
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/modules/iana-crypt-hash@2014-08-06.yang $(1)/etc/sysrepo/yang/
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/modules/ietf-tcp-server@2019-07-02.yang $(1)/etc/sysrepo/yang/
$(INSTALL_DIR) $(1)/etc/uci-defaults
$(INSTALL_BIN) ./files/netopeer2-server.default $(1)/etc/uci-defaults/98_netopeer2-server
@@ -97,16 +101,13 @@ define Package/netopeer2-server/install
endef
define Package/netopeer2-cli/install
- $(INSTALL_DIR) $(1)/bin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/cli/netopeer2-cli $(1)/bin/
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/netopeer2-cli $(1)/usr/bin/
endef
define Package/netopeer2-keystored/install
- $(INSTALL_DIR) $(1)/usr/lib/sysrepo/plugins/
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/keystored/libkeystored.so $(1)/usr/lib/sysrepo/plugins/
-
$(INSTALL_DIR) $(1)/etc/sysrepo/yang
- $(INSTALL_DATA) $(PKG_BUILD_DIR)/modules/ietf-keystore.yang $(1)/etc/sysrepo/yang/ietf-keystore@2016-10-31.yang
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/modules/ietf-keystore@2019-07-02.yang $(1)/etc/sysrepo/yang/
$(INSTALL_DIR) $(1)/etc/uci-defaults
@@ -120,8 +121,6 @@ else
$(INSTALL_DATA) ./files/ssh_host_rsa_key.pub.pem $(1)/etc/keystored/keys
endif
- $(INSTALL_DIR) $(1)/usr/share/netopeer2-keystored
- $(INSTALL_DATA) $(PKG_BUILD_DIR)/keystored/stock_key_config.xml $(1)/usr/share/netopeer2-keystored
endef
$(eval $(call BuildPackage,netopeer2-server))
diff --git a/net/Netopeer2/files/netopeer2-keystored-keygen.default b/net/Netopeer2/files/netopeer2-keystored-keygen.default
index 30e06a13d..aa8bb9931 100644
--- a/net/Netopeer2/files/netopeer2-keystored-keygen.default
+++ b/net/Netopeer2/files/netopeer2-keystored-keygen.default
@@ -5,7 +5,7 @@
if [ -x /bin/sysrepoctl ]; then
match=$(sysrepoctl -l | grep "ietf-keystore ")
if [ ! "$match" ]; then
- sysrepoctl --install --yang=/etc/sysrepo/yang/ietf-keystore@2016-10-31.yang -o root:root -p 600
+ sysrepoctl --install --yang=/etc/sysrepo/yang/ietf-keystore@2019-07-02.yang -o root:root -p 600
if [ -x /bin/sysrepocfg ]; then
sysrepocfg -f xml -d startup -i /usr/share/netopeer2-keystored/stock_key_config.xml ietf-keystore
rm /usr/share/netopeer2-keystored/stock_key_config.xml
diff --git a/net/Netopeer2/files/netopeer2-keystored.default b/net/Netopeer2/files/netopeer2-keystored.default
index 5257e5348..4ec74e929 100644
--- a/net/Netopeer2/files/netopeer2-keystored.default
+++ b/net/Netopeer2/files/netopeer2-keystored.default
@@ -5,7 +5,7 @@
if [ -x /bin/sysrepoctl ]; then
match=$(sysrepoctl -l | grep "ietf-keystore ")
if [ ! "$match" ]; then
- sysrepoctl --install --yang=/etc/sysrepo/yang/ietf-keystore@2016-10-31.yang -o root:root -p 600
+ sysrepoctl --install --yang=/etc/sysrepo/yang/ietf-keystore@2019-07-02.yang -o root:root -p 600
if [ -x /bin/sysrepocfg ]; then
sysrepocfg -f xml -d startup -i /usr/share/netopeer2-keystored/stock_key_config.xml ietf-keystore
rm /usr/share/netopeer2-keystored/stock_key_config.xml
diff --git a/net/Netopeer2/files/netopeer2-server.default b/net/Netopeer2/files/netopeer2-server.default
index 991eb3b17..ec91d2042 100644
--- a/net/Netopeer2/files/netopeer2-server.default
+++ b/net/Netopeer2/files/netopeer2-server.default
@@ -5,12 +5,12 @@
if [ -x /bin/sysrepoctl ]; then
match=$(sysrepoctl -l | grep "ietf-ssh-server ")
if [ ! "$match" ]; then
- sysrepoctl --install --yang=/etc/sysrepo/yang/ietf-ssh-server@2016-11-02.yang -p 600
+ sysrepoctl --install --yang=/etc/sysrepo/yang/ietf-ssh-server@2019-07-02.yang -p 600
fi
match=$(sysrepoctl -l | grep "ietf-tls-server ")
if [ ! "$match" ]; then
- sysrepoctl --install --yang=/etc/sysrepo/yang/ietf-tls-server@2016-11-02.yang -p 600
+ sysrepoctl --install --yang=/etc/sysrepo/yang/ietf-tls-server@2019-07-02.yang -p 600
fi
match=$(sysrepoctl -l | grep "iana-crypt-hash ")
@@ -25,7 +25,7 @@ if [ -x /bin/sysrepoctl ]; then
match=$(sysrepoctl -l | grep "ietf-netconf-server ")
if [ ! "$match" ]; then
- sysrepoctl --install --yang=/etc/sysrepo/yang/ietf-netconf-server@2016-11-02.yang -o root:root -p 600
+ sysrepoctl --install --yang=/etc/sysrepo/yang/ietf-netconf-server@2019-07-02.yang -o root:root -p 600
sysrepoctl -m ietf-netconf-server -e listen
sysrepoctl -m ietf-netconf-server -e ssh-listen
sysrepoctl -m ietf-netconf-server -e tls-listen
@@ -46,14 +46,7 @@ if [ -x /bin/sysrepoctl ]; then
match=$(sysrepoctl -l | grep "ietf-netconf-with-defaults ")
if [ ! "$match" ]; then
- sysrepoctl --install --yang=/etc/sysrepo/yang/ietf-netconf-with-defaults@2011-06-01.yang -o root:root -p 600
- fi
-
- match=$(sysrepoctl -l | grep "ietf-system ")
- if [ ! "$match" ]; then
- sysrepoctl --install --yang=/etc/sysrepo/yang/ietf-system@2014-08-06.yang -o root:root -p 600
- sysrepoctl -m ietf-system -e authentication
- sysrepoctl -m ietf-system -e local-users
+ sysrepoctl --install --yang=/etc/sysrepo/yang/ietf-netconf@2013-09-29.yang -o root:root -p 600
fi
match=$(sysrepoctl -l | grep "ietf-datastores ")
@@ -61,10 +54,6 @@ if [ -x /bin/sysrepoctl ]; then
sysrepoctl --install --yang=/etc/sysrepo/yang/ietf-datastores@2017-08-17.yang -o root:root -p 600
fi
- match=$(sysrepoctl -l | grep "ietf-yang-library ")
- if [ ! "$match" ]; then
- sysrepoctl --install --yang=/etc/sysrepo/yang/ietf-yang-library@2018-01-17.yang -o root:root -p 600
- fi
fi
exit 0
diff --git a/net/Netopeer2/patches/001-fix-for-cmake-build.patch b/net/Netopeer2/patches/001-fix-for-cmake-build.patch
deleted file mode 100644
index ce69ee3a2..000000000
--- a/net/Netopeer2/patches/001-fix-for-cmake-build.patch
+++ /dev/null
@@ -1,68 +0,0 @@
---- /dev/null
-+++ b/CMakeLists.txt
-@@ -0,0 +1,5 @@
-+cmake_minimum_required(VERSION 2.6)
-+
-+add_subdirectory(server)
-+add_subdirectory(cli)
-+add_subdirectory(keystored)
---- a/cli/CMakeLists.txt
-+++ b/cli/CMakeLists.txt
-@@ -1,7 +1,7 @@
- cmake_minimum_required(VERSION 2.6)
-
- # include custom Modules
--set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/../CMakeModules/")
-+set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/CMakeModules/")
-
- project(netopeer2-cli C)
- include(GNUInstallDirs)
-@@ -84,7 +84,7 @@ endif()
- install(FILES ${PROJECT_SOURCE_DIR}/doc/${PROJECT_NAME}.1 DESTINATION ${CMAKE_INSTALL_MANDIR}/man1)
-
- # clean cmake cache
--add_custom_target(cleancache
-+add_custom_target(cleancache_cli
- COMMAND make clean
- COMMAND find . -iname '*cmake*' -not -name CMakeLists.txt -exec rm -rf {} +
- COMMAND rm -rf Makefile Doxyfile
---- a/keystored/CMakeLists.txt
-+++ b/keystored/CMakeLists.txt
-@@ -1,7 +1,7 @@
- cmake_minimum_required(VERSION 2.6)
-
- # include custom Modules
--set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/../CMakeModules/")
-+set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/CMakeModules/")
-
- project(keystored C)
- include(GNUInstallDirs)
-@@ -147,7 +147,7 @@ if (SSH_KEY_INSTALL)
- execute_process(COMMAND ${CMAKE_CURRENT_SOURCE_DIR}/scripts/ssh-key-import.sh)")
- endif()
-
--add_custom_target(install-scripts-ide
-+add_custom_target(install-scripts-ide-keystored
- scripts/model-install.sh
- scripts/ssh-key-import.sh
- )
---- a/server/CMakeLists.txt
-+++ b/server/CMakeLists.txt
-@@ -1,7 +1,7 @@
- cmake_minimum_required(VERSION 2.8.9)
-
- # include custom Modules
--set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/../CMakeModules/")
-+set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/CMakeModules/")
-
- project(netopeer2-server C)
- include(GNUInstallDirs)
-@@ -208,7 +208,7 @@ if (ENABLE_CONFIGURATION)
- execute_process(COMMAND ${PROJECT_BINARY_DIR}/model-install.sh)")
- endif()
-
--add_custom_target(install-scripts-ide
-+add_custom_target(install-scripts-ide-server
- ${PROJECT_BINARY_DIR}/model-install.sh
- )
-
diff --git a/net/Netopeer2/patches/001-openss_1.1_support.patch b/net/Netopeer2/patches/001-openss_1.1_support.patch
new file mode 100644
index 000000000..a4d5b4cac
--- /dev/null
+++ b/net/Netopeer2/patches/001-openss_1.1_support.patch
@@ -0,0 +1,11 @@
+--- a/cli/commands.c 2020-05-08 16:29:28.284509842 +0300
++++ b/cli/commands.c 2020-05-08 16:29:38.856397844 +0300
+@@ -1725,7 +1725,7 @@
+ BIO_printf(bio_out, "\n");
+
+ BIO_printf(bio_out, "Valid until: ");
+- ASN1_TIME_print(bio_out, X509_get_notAfter(cert));
++ ASN1_TIME_print(bio_out, X509_get0_notAfter(cert));
+ BIO_printf(bio_out, "\n");
+
+ has_san = 0;
diff --git a/net/Netopeer2/patches/002-fix-keystored-cross-compile.patch b/net/Netopeer2/patches/002-fix-keystored-cross-compile.patch
deleted file mode 100644
index db30cd421..000000000
--- a/net/Netopeer2/patches/002-fix-keystored-cross-compile.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- a/keystored/CMakeLists.txt
-+++ b/keystored/CMakeLists.txt
-@@ -69,6 +69,8 @@ find_package(SYSREPO REQUIRED)
- target_link_libraries(keystored ${SYSREPO_LIBRARIES})
- include_directories(${SYSREPO_INCLUDE_DIRS})
-
-+# skip step because of cross compiling
-+if (FALSE)
- # get sysrepo plugins directory
- if (NOT SR_PLUGINS_DIR)
- if (PKG_CONFIG_FOUND)
-@@ -154,3 +156,4 @@ add_custom_target(install-scripts-ide
-
- # plugins should be installed into sysrepo plugins dir
- install(TARGETS keystored DESTINATION ${SR_PLUGINS_DIR})
-+endif()
diff --git a/net/sysrepo/Makefile b/net/sysrepo/Makefile
index 6843f123d..d3eb3878b 100644
--- a/net/sysrepo/Makefile
+++ b/net/sysrepo/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=sysrepo
-PKG_VERSION:=1.4.2
+PKG_VERSION:=1.4.58
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/sysrepo/sysrepo/tar.gz/v$(PKG_VERSION)?
-PKG_HASH:=d84d4f092feab83b0a39fef5d0d62bc6ed1f0f8aa274329f2cbf0a95a6528d8a
+PKG_HASH:=9c134658a5b812cd86b9113c30fc01be5a094616f473e747032ccf614af9e4dd
PKG_MAINTAINER:=Mislav Novakovic <mislav.novakovic@sartura.hr>
PKG_LICENSE:=Apache-2.0