aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-06-25 22:17:59 -0700
committerGitHub <noreply@github.com>2020-06-25 22:17:59 -0700
commitc7dca50f110d5458ceff21a2274eddae2aae119b (patch)
tree3943e25f13af1d81598bfeabba5008c04b71e13f /net
parentb867631f7cde40cc2cdd65343936e931a315bd7a (diff)
parentd2f4454fe61caccefecc28f8add8f6d4219b5bb5 (diff)
Merge pull request #12613 from stangri/master-https-dns-proxy
https-dns-proxy: re-add conffiles and add description to Makefile
Diffstat (limited to 'net')
-rw-r--r--net/https-dns-proxy/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/net/https-dns-proxy/Makefile b/net/https-dns-proxy/Makefile
index 61ee5b42d..bb820b789 100644
--- a/net/https-dns-proxy/Makefile
+++ b/net/https-dns-proxy/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=https-dns-proxy
PKG_VERSION:=2020-04-09
-PKG_RELEASE=2
+PKG_RELEASE=3
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/aarond10/https_dns_proxy
@@ -26,6 +26,15 @@ define Package/https-dns-proxy
CONFLICTS:=https_dns_proxy
endef
+define Package/https-dns-proxy/description
+https_dns_proxy is a light-weight DNS<-->HTTPS, non-caching translation proxy for the RFC 8484 DNS-over-HTTPS standard. It receives regular (UDP) DNS requests and issues them via DoH.
+Please see https://github.com/openwrt/packages/blob/master/net/https-dns-proxy/files/README.md for further information.
+endef
+
+define Package/https-dns-proxy/conffiles
+/etc/config/https-dns-proxy
+endef
+
define Package/https-dns-proxy/install
$(INSTALL_DIR) $(1)/usr/sbin $(1)/etc/init.d ${1}/etc/config
$(INSTALL_BIN) $(PKG_BUILD_DIR)/https_dns_proxy $(1)/usr/sbin/https-dns-proxy