aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorAndreas Nilsen <adde88@gmail.com>2020-02-02 13:56:30 +0100
committerAndreas Nilsen <adde88@gmail.com>2020-02-03 17:17:42 +0100
commitc7cf60ab401909c8bab6a094986fe2a645a29553 (patch)
treeb11c9f411cc1ee04f33d21a6a68c43d06b423f5e /net
parente48b08d48667bba9dc422c557aec446ffa67723a (diff)
hcxtools: update to 5.3.0. + Changes to Makefile to include latest binaries being compiled
Signed-off-by: Andreas Nilsen <adde88@gmail.com> hcxdumptool: forgot to add new openssl dependency Signed-off-by: Andreas Nilsen <adde88@gmail.com>
Diffstat (limited to 'net')
2 files changed, 26 insertions, 24 deletions
diff --git a/net/hcxdumptool/Makefile b/net/hcxdumptool/Makefile
index 611911865..0f2cddf5d 100644
--- a/net/hcxdumptool/Makefile
+++ b/net/hcxdumptool/Makefile
@@ -24,7 +24,7 @@ include $(INCLUDE_DIR)/package.mk
define Package/hcxdumptool
SECTION:=net
CATEGORY:=Network
- DEPENDS:=+libpcap
+ DEPENDS:=+libpcap +libopenssl
TITLE:=hcxdumptool
URL:=https://github.com/ZerBea/hcxdumptool
SUBMENU:=Wireless
diff --git a/net/hcxtools/Makefile b/net/hcxtools/Makefile
index 388a97ca0..143bc447f 100644
--- a/net/hcxtools/Makefile
+++ b/net/hcxtools/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=hcxtools
-PKG_VERSION:=5.2.2
+PKG_VERSION:=5.3.0
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/zerbea/hcxtools/tar.gz/$(PKG_VERSION)?
-PKG_HASH:=a2dd9559e1cc541f07f7a4c2451c295896355a94cfc970dc5cdceb40e605ee7e
+PKG_HASH:=bc3465eb3b97c4db849af41ae3fa7c812d4683eb9e493f090ac82e922ba8a36d
PKG_MAINTAINER:=Andreas Nilsen <adde88@gmail.com>
PKG_LICENSE:=MIT
@@ -41,27 +41,29 @@ define Build/Compile
CFLAGS="$(TARGET_CFLAGS)"
endef
-define Package/hcxtools/install
- $(INSTALL_DIR) $(1)/usr/sbin
- $(INSTALL_DIR) $(1)/etc
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/wlanwkp2hcx $(1)/usr/sbin/
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/wlanpmk2hcx $(1)/usr/sbin/
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/wlanhcxmnc $(1)/usr/sbin/
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/wlanhcx2essid $(1)/usr/sbin/
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/wlanjohn2hcx $(1)/usr/sbin/
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxpcaptool $(1)/usr/sbin/
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/wlanhcx2john $(1)/usr/sbin/
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxpsktool $(1)/usr/sbin/
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/wlancow2hcxpmk $(1)/usr/sbin/
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/wlanhcxinfo $(1)/usr/sbin/
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxhash2cap $(1)/usr/sbin/
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxhashcattool $(1)/usr/sbin/
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/wlanhashhcx $(1)/usr/sbin/
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/wlancap2wpasec $(1)/usr/sbin/
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/wlanhc2hcx $(1)/usr/sbin/
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxwltool $(1)/usr/sbin/
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/whoismac $(1)/usr/sbin/
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/wlancap2wpasec $(1)/usr/sbin/
+define Package/hcxtools-custom/install
+ $(INSTALL_DIR) $(1)/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxpcapngtool $(1)/sbin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxhashtool $(1)/sbin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxpsktool $(1)/sbin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxwltool $(1)/sbin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/wlancap2wpasec $(1)/sbin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/whoismac $(1)/sbin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxpmkidtool $(1)/sbin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/wlanhcx2john $(1)/sbin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxpcaptool $(1)/sbin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxhashcattool $(1)/sbin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxmactool $(1)/sbin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxessidtool $(1)/sbin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxhash2cap $(1)/sbin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/wlanhc2hcx $(1)/sbin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/wlanwkp2hcx $(1)/sbin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/wlanhcxinfo $(1)/sbin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/wlanhcx2ssid $(1)/sbin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/wlanhcxcat $(1)/sbin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/wlanpmk2hcx $(1)/sbin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/wlanjohn2hcx $(1)/sbin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/wlancow2hcxpmk $(1)/sbin/
endef
$(eval $(call BuildPackage,hcxtools))