aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorPeter Wagner <tripolar@gmx.at>2018-03-13 19:08:56 +0100
committerPeter Wagner <tripolar@gmx.at>2018-03-13 19:09:43 +0100
commitc57adab9f1609dbd09911bc79b967276aeaa8168 (patch)
tree9991e099c097da9a0d42ecaf016c1ed0304b98c2 /net
parent47df65608f0f2da5483b33700023272eddd7c55a (diff)
git: use hardlinks for /usr/lib/git-core/git{,-shell,-upload-pack}
Signed-off-by: Peter Wagner <tripolar@gmx.at>
Diffstat (limited to 'net')
-rw-r--r--net/git/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/net/git/Makefile b/net/git/Makefile
index 1879c4987..b2d8e2c93 100644
--- a/net/git/Makefile
+++ b/net/git/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=git
PKG_VERSION:=2.16.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@KERNEL/software/scm/git/
@@ -110,7 +110,9 @@ define Package/git/install
$(RM) $(PKG_INSTALL_DIR)/usr/bin/git-cvsserver
$(CP) $(PKG_INSTALL_DIR)/usr/bin/git-* $(1)/usr/bin
$(INSTALL_DIR) $(1)/usr/lib/git-core
- $(LN) /usr/bin/git $(1)/usr/lib/git-core/git
+ ln $(1)/usr/bin/git $(1)/usr/lib/git-core/git
+ ln $(1)/usr/bin/git-shell $(1)/usr/lib/git-core/git-shell
+ ln $(1)/usr/bin/git-upload-pack $(1)/usr/lib/git-core/git-upload-pack
$(INSTALL_DIR) $(1)/usr/share/git-core/templates
( cd $(PKG_INSTALL_DIR); $(TAR) \
--exclude=usr/lib/git-core/git-http-backend \
@@ -119,6 +121,9 @@ define Package/git/install
--exclude=usr/lib/git-core/git-remote-ftps \
--exclude=usr/lib/git-core/git-remote-http \
--exclude=usr/lib/git-core/git-remote-https \
+ --exclude=usr/lib/git-core/git \
+ --exclude=usr/lib/git-core/git-shell \
+ --exclude=usr/lib/git-core/git-upload-pack \
-cf - \
usr/lib/git-core \
usr/share/git-core/templates \