aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2021-11-20 11:55:01 +0000
committerDaniel Golle <daniel@makrotopia.org>2021-11-20 11:57:10 +0000
commitc2f2e1706aab8c1e85d66869a85a7fefa9b1523a (patch)
tree4dc4391e5da30d408f919bfe8458c260d187ee93 /net
parentda619f19f436bc95acd07c0d7aca772328cc5895 (diff)
transmission: add a bunch of syscalls to seccomp filter
Add missing "inotify_add_watch", "inotify_init1" and "inotify_rm_watch" syscalls to seccomp filter which are needed in case watch_dir feature of transmission is used. Fixes #16972 Reported-by: @siwind Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'net')
-rw-r--r--net/transmission/Makefile2
-rw-r--r--net/transmission/files/transmission-daemon.json3
2 files changed, 4 insertions, 1 deletions
diff --git a/net/transmission/Makefile b/net/transmission/Makefile
index 8c1e61061..7434dd4ba 100644
--- a/net/transmission/Makefile
+++ b/net/transmission/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=transmission
PKG_VERSION:=3.00
-PKG_RELEASE:=15
+PKG_RELEASE:=16
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@GITHUB/transmission/transmission-releases/master
diff --git a/net/transmission/files/transmission-daemon.json b/net/transmission/files/transmission-daemon.json
index 41c3a7d86..b652d3257 100644
--- a/net/transmission/files/transmission-daemon.json
+++ b/net/transmission/files/transmission-daemon.json
@@ -42,6 +42,9 @@
"getsockopt",
"getuid",
"getuid32",
+ "inotify_add_watch",
+ "inotify_init1",
+ "inotify_rm_watch",
"ioctl",
"listen",
"_llseek",