aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorChristian Schoenebeck <christian.schoenebeck@gmail.com>2014-10-06 21:49:47 +0200
committerChristian Schoenebeck <christian.schoenebeck@gmail.com>2014-10-06 21:49:47 +0200
commitbc175726cd1a0fdc0b9a767344866df4679538ba (patch)
tree2aef7a9851fbf3a873ae35f718c676f6da164e67 /net
parenta6a3037fbdda502a22528a58c342ea2e3bdb081a (diff)
ddns-scripts: fix problem during startup
fixes problem CRITICAL ERROR - custom update_script not found when extracting url and script from services / services_ipv6 file Signed-off-by: Christian Schoenebeck <christian.schoenebeck@gmail.com>
Diffstat (limited to 'net')
-rw-r--r--net/ddns-scripts/Makefile2
-rw-r--r--net/ddns-scripts/files/usr/lib/ddns/dynamic_dns_functions.sh2
-rwxr-xr-xnet/ddns-scripts/files/usr/lib/ddns/dynamic_dns_updater.sh1
3 files changed, 2 insertions, 3 deletions
diff --git a/net/ddns-scripts/Makefile b/net/ddns-scripts/Makefile
index 5d2cafce7..71ab4b66e 100644
--- a/net/ddns-scripts/Makefile
+++ b/net/ddns-scripts/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=ddns-scripts
PKG_VERSION:=2.0.1
-PKG_RELEASE:=7
+PKG_RELEASE:=8
PKG_LICENSE:=GPL-2.0
PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
diff --git a/net/ddns-scripts/files/usr/lib/ddns/dynamic_dns_functions.sh b/net/ddns-scripts/files/usr/lib/ddns/dynamic_dns_functions.sh
index b2cb237d9..33aeb1979 100644
--- a/net/ddns-scripts/files/usr/lib/ddns/dynamic_dns_functions.sh
+++ b/net/ddns-scripts/files/usr/lib/ddns/dynamic_dns_functions.sh
@@ -247,7 +247,7 @@ get_service_data() {
IFS=$__OLD_IFS
# check is URL or SCRIPT is given
- __URL=$(echo "$__URL" | grep "^http:")
+ __URL=$(echo "$__DATA" | grep "^http:")
[ -z "$__URL" ] && __SCRIPT="/usr/lib/ddns/$__DATA"
eval "$1='$__URL'"
diff --git a/net/ddns-scripts/files/usr/lib/ddns/dynamic_dns_updater.sh b/net/ddns-scripts/files/usr/lib/ddns/dynamic_dns_updater.sh
index 77f9e1ac8..3892c69d8 100755
--- a/net/ddns-scripts/files/usr/lib/ddns/dynamic_dns_updater.sh
+++ b/net/ddns-scripts/files/usr/lib/ddns/dynamic_dns_updater.sh
@@ -117,7 +117,6 @@ load_all_config_options "ddns" "$SECTION_ID"
verbose_echo "\n ************** =: ************** ************** **************"
verbose_echo " STARTED =: PID '$$' at $(eval $DATE_PROG)"
-syslog_info "Started"
case $VERBOSE_MODE in
0) verbose_echo " verbose mode =: '0' - run normal, NO console output";;
1) verbose_echo " verbose mode =: '1' - run normal, console mode";;