aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2022-03-01 20:22:59 +0200
committerRosen Penev <rosenp@gmail.com>2022-03-04 06:28:08 -0800
commitbc09311c380298aa5509ef81f120e44fe64c759a (patch)
treecd5d78da4deab04e0b5dd476c7549591621c205d /net
parent938b9b42a6db52fa999b05c77811b476882f0b0c (diff)
strongswan: add missing dependencies
Fix the following build failures by adding the missing dependencies: Package strongswan-mod-connmark is missing dependencies for the following libraries: libip4tc.so.2 Package strongswan-mod-forecast is missing dependencies for the following libraries: libip4tc.so.2 Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Diffstat (limited to 'net')
-rw-r--r--net/strongswan/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/net/strongswan/Makefile b/net/strongswan/Makefile
index 5ffcff00d..241a58bda 100644
--- a/net/strongswan/Makefile
+++ b/net/strongswan/Makefile
@@ -673,7 +673,7 @@ $(eval $(call BuildPlugin,blowfish,Blowfish crypto,))
$(eval $(call BuildPlugin,ccm,CCM AEAD wrapper crypto,))
$(eval $(call BuildPlugin,chapoly,ChaCha20-Poly1305 AEAD crypto,))
$(eval $(call BuildPlugin,cmac,CMAC crypto,))
-$(eval $(call BuildPlugin,connmark,netfilter connection marking,))
+$(eval $(call BuildPlugin,connmark,netfilter connection marking,+iptables-legacy))
$(eval $(call BuildPlugin,constraints,advanced X509 constraint checking,))
$(eval $(call BuildPlugin,coupling,IKEv2 plugin to couple peer certificates permanently to authentication,))
$(eval $(call BuildPlugin,ctr,Counter Mode wrapper crypto,))
@@ -690,7 +690,7 @@ $(eval $(call BuildPlugin,eap-radius,EAP RADIUS auth,))
$(eval $(call BuildPlugin,eap-tls,EAP TLS auth,+strongswan-libtls))
$(eval $(call BuildPlugin,farp,fake arp respsonses,))
$(eval $(call BuildPlugin,fips-prf,FIPS PRF crypto,+strongswan-mod-sha1))
-$(eval $(call BuildPlugin,forecast,forward multi/broadcast traffic,+kmod-ipt-conntrack-extra))
+$(eval $(call BuildPlugin,forecast,forward multi/broadcast traffic,+iptables-legacy +kmod-ipt-conntrack-extra))
$(eval $(call BuildPlugin,gcm,GCM AEAD wrapper crypto,))
$(eval $(call BuildPlugin,gcrypt,libgcrypt,+PACKAGE_strongswan-mod-gcrypt:libgcrypt))
$(eval $(call BuildPlugin,gmp,libgmp,+PACKAGE_strongswan-mod-gmp:libgmp))