aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>2020-05-10 13:39:09 +0100
committerKevin Darbyshire-Bryant <6500011+ldir-EDB0@users.noreply.github.com>2020-05-10 17:30:11 +0100
commitb7c59c390f0b739403ae9099e1affe94d214b51d (patch)
tree2d1e0726d854789c345f92197e7dead501aeaaeb /net
parent83d36065d5e678f3309375f5d07188f960a6850f (diff)
miniupnpd: make hotplug work again
hotplug scripts are sourced not exec'd so #!/bin/sh /etc/rc.common doesn't pull in the functions defined in /etc/rc.common thus since 'enabled' isn't defined the following sequence always fails: enabled miniupnpd || exit 0 Unfortunately sourcing /etc/rc.common doesn't appear to work so come up with some alternatives. Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Diffstat (limited to 'net')
-rw-r--r--net/miniupnpd/Makefile2
-rw-r--r--net/miniupnpd/files/miniupnpd.hotplug12
2 files changed, 7 insertions, 7 deletions
diff --git a/net/miniupnpd/Makefile b/net/miniupnpd/Makefile
index 5d03cdce6..4d255dab2 100644
--- a/net/miniupnpd/Makefile
+++ b/net/miniupnpd/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=miniupnpd
PKG_VERSION:=2.1.20191006
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE_URL:=https://miniupnp.tuxfamily.org/files
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
diff --git a/net/miniupnpd/files/miniupnpd.hotplug b/net/miniupnpd/files/miniupnpd.hotplug
index 9e525f9b5..9664b54ba 100644
--- a/net/miniupnpd/files/miniupnpd.hotplug
+++ b/net/miniupnpd/files/miniupnpd.hotplug
@@ -1,15 +1,15 @@
-#!/bin/sh /etc/rc.common
-
-enabled miniupnpd || exit 0
+/etc/init.d/miniupnpd enabled || exit 0
# If miniupnpd is not running:
-# - check on _any_ event (even updates may contribute to network_find_wan*)
+# - check on _any_ event (event updates may contribute to network_find_wan*)
# If miniupnpd _is_ running:
# - check only on ifup (otherwise lease updates etc would cause
# miniupnpd state loss)
-[ "$ACTION" != "ifup" ] && service_running miniupnpd && exit 0
+. /lib/functions/procd.sh
+
+[ "$ACTION" != "ifup" ] && procd_running "miniupnpd" "*" && exit 0
tmpconf="/var/etc/miniupnpd.conf"
extiface=$(uci get upnpd.config.external_iface)
@@ -20,7 +20,7 @@ extzone=$(uci get upnpd.config.external_zone)
[ -z "$extiface" ] && {
# manual external zone (if dynamically find interfaces
# belonging to it) overrides network_find_wan*
- [ -n "$extzone" ] && ifname=$(fw3 -q zone "$extzone" | head -1)
+ [ -n "$extzone" ] && ifname=$(fw3 -q zone "$extzone" | head -1)
[ -z "$extiface" ] && network_find_wan extiface
[ -z "$extiface" ] && network_find_wan6 extiface
}