aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorSebastian Kemper <sebastian_ml@gmx.net>2018-07-13 22:22:54 +0200
committerSebastian Kemper <sebastian_ml@gmx.net>2018-07-13 22:22:56 +0200
commitb43e63b66d1a1f5ef9f0c5cd2e295124340e7cb2 (patch)
treebe4cc89d6dee58411e8328bb1fe19ff31ef49196 /net
parente63960f24e15b692ab3ed3cf5c0517039c45e367 (diff)
lighttpd: fix CONFIGURE_ARGS
With the current layout CONFIGURE_ARGS can end up like this: --with-mysql --without-mysql To avoid that join the ifneqs of the two mysql related plugins. Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
Diffstat (limited to 'net')
-rw-r--r--net/lighttpd/Makefile10
1 files changed, 2 insertions, 8 deletions
diff --git a/net/lighttpd/Makefile b/net/lighttpd/Makefile
index 92d87b8e0..20ef50ea7 100644
--- a/net/lighttpd/Makefile
+++ b/net/lighttpd/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2015 OpenWrt.org
+# Copyright (C) 2006-2018 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -92,7 +92,7 @@ else
CONFIGURE_ARGS+= --without-ldap
endif
-ifneq ($(SDK)$(CONFIG_PACKAGE_lighttpd-mod-authn_mysql),)
+ifneq ($(SDK)$(CONFIG_PACKAGE_lighttpd-mod-authn_mysql)$(CONFIG_PACKAGE_lighttpd-mod-mysql_vhost),)
CONFIGURE_ARGS+= --with-mysql
else
CONFIGURE_ARGS+= --without-mysql
@@ -110,12 +110,6 @@ else
CONFIGURE_ARGS+= --without-lua
endif
-ifneq ($(SDK)$(CONFIG_PACKAGE_lighttpd-mod-mysql_vhost),)
- CONFIGURE_ARGS+= --with-mysql
-else
- CONFIGURE_ARGS+= --without-mysql
-endif
-
#ifneq ($(SDK)$(CONFIG_PACKAGE_lighttpd-mod-cml)$(CONFIG_PACKAGE_lighttpd-mod-trigger_b4_dl),)
# CONFIGURE_ARGS+= --with-memcached
#else