aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorDaniel Engberg <daniel.engberg.lists@pyret.net>2019-08-06 23:51:49 +0200
committerGitHub <noreply@github.com>2019-08-06 23:51:49 +0200
commitb2f0cb973ecaf8a878f2d7b97fab96ce4e0bc302 (patch)
treecfa80a5316f8cc694cb653440b570fb2098c2010 /net
parent6fb488a44146584d3b30a589ac069d76ceaf99e5 (diff)
parenta33a891308204f268cbbb8a7821fb6962f705641 (diff)
Merge pull request #9602 from dengqf6/ngx-br
nginx: update brotli module
Diffstat (limited to 'net')
-rw-r--r--net/nginx/Makefile8
-rw-r--r--net/nginx/files-luci-support/luci_nginx.conf7
-rw-r--r--net/nginx/files-luci-support/luci_nginx_ssl.conf11
3 files changed, 14 insertions, 12 deletions
diff --git a/net/nginx/Makefile b/net/nginx/Makefile
index 85f97bc9d..50635960d 100644
--- a/net/nginx/Makefile
+++ b/net/nginx/Makefile
@@ -429,18 +429,18 @@ endif
ifeq ($(CONFIG_NGINX_HTTP_BROTLI),y)
define Download/nginx-brotli
- VERSION:=e26248ee361c04e25f581b92b85d95681bdffb39
+ VERSION:=dc37f658ccb5a51d090dc09d1a2aca2f24309869
SUBDIR:=nginx-brotli
- FILE:=ngx-brotli-module-$$(VERSION).tar.gz
+ FILE:=ngx-brotli-module-$$(VERSION).tar.xz
URL:=https://github.com/eustas/ngx_brotli.git
- MIRROR_HASH:=76b891ba49f82f0cfbc9cba875646e26ee986b522373e0aa2698a9923a4adcdb
+ MIRROR_HASH:=6bc0c40ff24f6e0ac616dfddc803bdc7fcf54764ba9dc4f9cecb3a68beedcdaf
PROTO:=git
endef
$(eval $(call Download,nginx-brotli))
define Prepare/nginx-brotli
$(eval $(Download/nginx-brotli))
- gzip -dc $(DL_DIR)/$(FILE) | tar -C $(PKG_BUILD_DIR) $(TAR_OPTIONS)
+ xzcat $(DL_DIR)/$(FILE) | tar -C $(PKG_BUILD_DIR) $(TAR_OPTIONS)
endef
endif
diff --git a/net/nginx/files-luci-support/luci_nginx.conf b/net/nginx/files-luci-support/luci_nginx.conf
index 31af664a2..5b0f3da0a 100644
--- a/net/nginx/files-luci-support/luci_nginx.conf
+++ b/net/nginx/files-luci-support/luci_nginx.conf
@@ -20,7 +20,7 @@ http {
sendfile on;
keepalive_timeout 0;
-
+
client_body_buffer_size 10K;
client_header_buffer_size 1k;
client_max_body_size 1G;
@@ -31,14 +31,15 @@ http {
gzip_vary on;
gzip_comp_level 1;
gzip_proxied any;
-
+ gzip_types text/plain text/css application/json application/x-javascript text/xml application/xml application/xml+rss text/javascript application/javascript image/svg+xml;
+
root /www;
server {
listen 80 default_server;
listen [::]:80 default_server;
server_name localhost;
-
+
location ~* .(jpg|jpeg|png|gif|ico|css|js)$ {
expires 365d;
}
diff --git a/net/nginx/files-luci-support/luci_nginx_ssl.conf b/net/nginx/files-luci-support/luci_nginx_ssl.conf
index 318453b54..db33e554c 100644
--- a/net/nginx/files-luci-support/luci_nginx_ssl.conf
+++ b/net/nginx/files-luci-support/luci_nginx_ssl.conf
@@ -20,7 +20,7 @@ http {
sendfile on;
keepalive_timeout 0;
-
+
client_body_buffer_size 10K;
client_header_buffer_size 1k;
client_max_body_size 1G;
@@ -31,9 +31,10 @@ http {
gzip_vary on;
gzip_comp_level 1;
gzip_proxied any;
-
+ gzip_types text/plain text/css application/json application/x-javascript text/xml application/xml application/xml+rss text/javascript application/javascript image/svg+xml;
+
root /www;
-
+
server {
listen 80 default_server;
listen [::]:80 default_server;
@@ -45,7 +46,7 @@ http {
listen 443 ssl default_server;
listen [::]:443 ssl default_server;
server_name localhost;
-
+
ssl_protocols TLSv1 TLSv1.1 TLSv1.2;
ssl_prefer_server_ciphers on;
ssl_ciphers "EECDH+ECDSA+AESGCM:EECDH+aRSA+AESGCM:EECDH+ECDSA+SHA384:EECDH+ECDSA+SHA256:EECDH+aRSA+SHA384:EECDH+aRSA+SHA256:EECDH:DHE+AESGCM:DHE:!RSA!aNULL:!eNULL:!LOW:!RC4:!3DES:!MD5:!EXP:!PSK:!SRP:!DSS:!CAMELLIA:!SEED";
@@ -53,7 +54,7 @@ http {
ssl_certificate /etc/nginx/nginx.cer;
ssl_certificate_key /etc/nginx/nginx.key;
-
+
location ~* .(jpg|jpeg|png|gif|ico|css|js)$ {
expires 365d;
}