aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorPhilip Prindeville <philipp@redfish-solutions.com>2024-04-02 13:03:53 -0600
committerPhilip Prindeville <philipp@redfish-solutions.com>2024-04-03 21:34:36 -0600
commitb014ae3f8628dff9196b82929f231b3dbf160fa9 (patch)
tree70c8d1dfeacb9ccbd92f25535e48b3a76a243e81 /net
parent428e9da9df4358f6893012cd60d9bd267db43ae5 (diff)
strongswan: Backport upstream fix for RNG definition conflict
Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
Diffstat (limited to 'net')
-rw-r--r--net/strongswan/Makefile2
-rw-r--r--net/strongswan/patches/0003-undef-wolfssl-RNG.patch39
-rw-r--r--net/strongswan/patches/0905-undef-wolfssl-RNG.patch12
3 files changed, 40 insertions, 13 deletions
diff --git a/net/strongswan/Makefile b/net/strongswan/Makefile
index b74095981..2ff7c8ee3 100644
--- a/net/strongswan/Makefile
+++ b/net/strongswan/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=strongswan
PKG_VERSION:=5.9.14
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://download.strongswan.org/ https://download2.strongswan.org/
diff --git a/net/strongswan/patches/0003-undef-wolfssl-RNG.patch b/net/strongswan/patches/0003-undef-wolfssl-RNG.patch
new file mode 100644
index 000000000..8f28c0fe8
--- /dev/null
+++ b/net/strongswan/patches/0003-undef-wolfssl-RNG.patch
@@ -0,0 +1,39 @@
+commit 5226561a77efc94b53d708a855df267b11f53b83
+Author: Philip Prindeville <philipp@redfish-solutions.com>
+Date: Wed Mar 27 17:41:18 2024 -0600
+
+ wolfssl: avoid RNG redefinition
+
+ There are definitions of RNG in <wolfcrypt/settings.h> and
+ <wolfcrypt/random.h> that play havoc with the literal RNG being
+ used in the expansions of _PLUGIN_FEATURE_RNG() => __PLUGIN_FEATURE()
+ in <plugins/plugin_feature.h> when ##-concatenated to build the
+ enum FEATURE_RNG.
+
+ <plugins/plugin_feature.h> must always be included before
+ <woldssl/ssl.h>, and RNG must be undefined before any plugins are
+ declared.
+
+ Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
+
+--- a/src/libstrongswan/plugins/wolfssl/wolfssl_common.h
++++ b/src/libstrongswan/plugins/wolfssl/wolfssl_common.h
+@@ -80,7 +80,4 @@ typedef union {
+
+ #undef PARSE_ERROR
+
+-/* Eliminate macro conflicts */
+-#undef RNG
+-
+ #endif /* WOLFSSL_PLUGIN_COMMON_H_ */
+--- a/src/libstrongswan/plugins/wolfssl/wolfssl_plugin.c
++++ b/src/libstrongswan/plugins/wolfssl/wolfssl_plugin.c
+@@ -47,6 +47,8 @@
+
+ #include <wolfssl/ssl.h>
+
++#undef RNG
++
+ #ifndef FIPS_MODE
+ #define FIPS_MODE 0
+ #endif
diff --git a/net/strongswan/patches/0905-undef-wolfssl-RNG.patch b/net/strongswan/patches/0905-undef-wolfssl-RNG.patch
deleted file mode 100644
index dfca722c9..000000000
--- a/net/strongswan/patches/0905-undef-wolfssl-RNG.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/src/libstrongswan/plugins/wolfssl/wolfssl_plugin.c
-+++ b/src/libstrongswan/plugins/wolfssl/wolfssl_plugin.c
-@@ -50,6 +50,9 @@
- #ifndef FIPS_MODE
- #define FIPS_MODE 0
- #endif
-+#ifdef RNG
-+#undef RNG
-+#endif
-
- typedef struct private_wolfssl_plugin_t private_wolfssl_plugin_t;
-