aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorKonstantin Demin <rockdrilla@gmail.com>2024-02-01 03:29:58 +0300
committerRosen Penev <rosenp@gmail.com>2024-02-04 16:05:08 -0800
commitaf748ea6915e16e91bcd8b5402e474cf745eea55 (patch)
tree7448d40d43395f4e5805faeafb3719ad32ad5777 /net
parent52a5e71b49dd3d10d57a20f4cb9e83aad8fbbc5e (diff)
libcurl-gnutls: update to version 8.6.0
https://curl.se/changes.html#8_6_0 Signed-off-by: Konstantin Demin <rockdrilla@gmail.com>
Diffstat (limited to 'net')
-rw-r--r--net/libcurl-gnutls/Makefile4
-rw-r--r--net/libcurl-gnutls/patches/0001-gnutls-fix-build-with-disable-verbose.patch54
2 files changed, 2 insertions, 56 deletions
diff --git a/net/libcurl-gnutls/Makefile b/net/libcurl-gnutls/Makefile
index edce0cf2c..8625dcbed 100644
--- a/net/libcurl-gnutls/Makefile
+++ b/net/libcurl-gnutls/Makefile
@@ -10,14 +10,14 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libcurl-gnutls
PKG_SOURCE_NAME:=curl
-PKG_VERSION:=8.5.0
+PKG_VERSION:=8.6.0
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_SOURCE_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://github.com/curl/curl/releases/download/curl-$(subst .,_,$(PKG_VERSION))/ \
https://dl.uxnr.de/mirror/curl/ \
https://curl.askapache.com/download/ \
https://curl.se/download/
-PKG_HASH:=ce4b6a6655431147624aaf582632a36fe1ade262d5fab385c60f78942dd8d87b
+PKG_HASH:=b4785f2d8877fa92c0e45d7155cf8cc6750dbda961f4b1a45bcbec990cf2fa9b
PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
PKG_LICENSE:=MIT
diff --git a/net/libcurl-gnutls/patches/0001-gnutls-fix-build-with-disable-verbose.patch b/net/libcurl-gnutls/patches/0001-gnutls-fix-build-with-disable-verbose.patch
deleted file mode 100644
index b05a244b1..000000000
--- a/net/libcurl-gnutls/patches/0001-gnutls-fix-build-with-disable-verbose.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-From af520ac9fec7d88e942f05fdcd90704adb9fa566 Mon Sep 17 00:00:00 2001
-From: Baruch Siach <baruch@tkos.co.il>
-Date: Mon, 11 Dec 2023 20:45:01 +0200
-Subject: [PATCH] gnutls: fix build with --disable-verbose
-
-infof() parameters must be defined event with --disable-verbose since
-commit dac293cfb702 ("lib: apache style infof and trace
-macros/functions").
-
-Move also 'ptr' definition under !CURL_DISABLE_VERBOSE_STRINGS.
-
-Fixes the following build failure:
-
-In file included from ../lib/sendf.h:29,
- from vtls/gtls.c:44:
-vtls/gtls.c: In function 'Curl_gtls_verifyserver':
-vtls/gtls.c:841:34: error: 'version' undeclared (first use in this function); did you mean 'session'?
- 841 | gnutls_protocol_get_name(version), ptr);
- | ^~~~~~~
-
-Closes #12505
----
- lib/vtls/gtls.c | 4 +++-
- 1 file changed, 3 insertions(+), 1 deletion(-)
-
---- a/lib/vtls/gtls.c
-+++ b/lib/vtls/gtls.c
-@@ -822,16 +822,17 @@ Curl_gtls_verifyserver(struct Curl_easy
- char certname[65] = ""; /* limited to 64 chars by ASN.1 */
- size_t size;
- time_t certclock;
-- const char *ptr;
- int rc;
- CURLcode result = CURLE_OK;
- #ifndef CURL_DISABLE_VERBOSE_STRINGS
-+ const char *ptr;
- unsigned int algo;
- unsigned int bits;
- gnutls_protocol_t version = gnutls_protocol_get_version(session);
- #endif
- long * const certverifyresult = &ssl_config->certverifyresult;
-
-+#ifndef CURL_DISABLE_VERBOSE_STRINGS
- /* the name of the cipher suite used, e.g. ECDHE_RSA_AES_256_GCM_SHA384. */
- ptr = gnutls_cipher_suite_get_name(gnutls_kx_get(session),
- gnutls_cipher_get(session),
-@@ -839,6 +840,7 @@ Curl_gtls_verifyserver(struct Curl_easy
-
- infof(data, "SSL connection using %s / %s",
- gnutls_protocol_get_name(version), ptr);
-+#endif
-
- /* This function will return the peer's raw certificate (chain) as sent by
- the peer. These certificates are in raw format (DER encoded for