aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-12-18 01:17:41 -0800
committerGitHub <noreply@github.com>2020-12-18 01:17:41 -0800
commitaa438f550b61d7df1ef01528df83408ac5f7925e (patch)
tree5d510aa2095327b53e0d73fe6f07ba1456ae40f4 /net
parente72192ce2da75f94c7804087cb3642cf83ca71aa (diff)
parentb2989d1c1d31f31949efedf6b4b8d13e25f29997 (diff)
Merge pull request #14265 from neheb/olap
protobuf: fix bad CFLAGS in pkgconfig
Diffstat (limited to 'net')
-rw-r--r--net/ola/Makefile2
-rw-r--r--net/ola/patches/010-no-werror.patch11
2 files changed, 12 insertions, 1 deletions
diff --git a/net/ola/Makefile b/net/ola/Makefile
index 7124415f7..a057f1f5e 100644
--- a/net/ola/Makefile
+++ b/net/ola/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=ola
PKG_VERSION:=0.10.8
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/OpenLightingProject/ola/tar.gz/$(PKG_VERSION)?
diff --git a/net/ola/patches/010-no-werror.patch b/net/ola/patches/010-no-werror.patch
new file mode 100644
index 000000000..44f5bdb8e
--- /dev/null
+++ b/net/ola/patches/010-no-werror.patch
@@ -0,0 +1,11 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -61,7 +61,7 @@ COMMON_TESTING_PROTOBUF_FLAGS = $(COMMON
+
+ # The generated protobuf files don't compile with -Werror on win32 so we
+ # disable fatal warnings on WIN32.
+-if ! USING_WIN32
++if USING_WIN32
+ if FATAL_WARNINGS
+ COMMON_CXXFLAGS += -Werror
+ COMMON_PROTOBUF_CXXFLAGS += -Werror -Wno-error=unused-parameter \