aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorTianling Shen <cnsztl@immortalwrt.org>2023-08-27 09:51:22 +0800
committerTianling Shen <cnsztl@immortalwrt.org>2023-08-27 09:51:22 +0800
commita86c47044d302c925bd3eec87fe3d83856b50f7d (patch)
tree4fde2cadf5ed65164324a47d2772fa88f7f71748 /net
parent846ee0b9d0a84ea0868c7f3a3a6bb2e1730c16d7 (diff)
v2raya: Update to 2.2.1
Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
Diffstat (limited to 'net')
-rw-r--r--net/v2raya/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/net/v2raya/Makefile b/net/v2raya/Makefile
index 5f548d1e7..f290183e8 100644
--- a/net/v2raya/Makefile
+++ b/net/v2raya/Makefile
@@ -5,12 +5,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=v2rayA
-PKG_VERSION:=2.1.3
+PKG_VERSION:=2.2.1
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/v2rayA/v2rayA/tar.gz/v$(PKG_VERSION)?
-PKG_HASH:=65958a02d91f849e264e409536d2fb3e4c7d2a8d3a6b82fed1b90cfaff3d6dc9
+PKG_HASH:=97ae3d41ddd649dd07cfecf2bbe06a513d71186ef2620ca44af12e7956be5650
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)/service
PKG_LICENSE:=AGPL-3.0-only
@@ -54,12 +54,12 @@ define Package/v2raya/conffiles
/etc/config/v2raya
endef
-WEB_FILE:=$(PKG_NAME)-web-$(PKG_VERSION).tar.gz
+WEB_FILE:=$(PKG_NAME)-web-$(PKG_VERSION).zip
define Download/v2raya-web
- URL:=https://codeload.github.com/v2rayA/v2raya-web/tar.gz/v$(PKG_VERSION)?
- URL_FILE:=$(WEB_FILE)
+ URL:=https://github.com/v2rayA/v2rayA/releases/download/v$(PKG_VERSION)/
+ URL_FILE:=web.zip
FILE:=$(WEB_FILE)
- HASH:=f262efe46b5377ceed0450f519ba8562a0e7553ec2cc34a4e62f95749b19be01
+ HASH:=b7769b287b6e2ecdf8823142d126bf9b981a8d3af4cb73c8f798ed483bcc988c
endef
define Build/Prepare
@@ -67,7 +67,7 @@ define Build/Prepare
( \
mkdir -p $(PKG_BUILD_DIR)/server/router/web ; \
- gzip -dc $(DL_DIR)/$(WEB_FILE) | $(HOST_TAR) -C $(PKG_BUILD_DIR)/server/router/web $(TAR_OPTIONS) ; \
+ unzip -q -d $(PKG_BUILD_DIR)/server/router/web $(DL_DIR)/$(WEB_FILE) ; \
)
endef