aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorFlorian Eckert <fe@dev.tdt.de>2024-05-07 13:55:36 +0200
committerGitHub <noreply@github.com>2024-05-07 13:55:36 +0200
commita2281fe2c7335e32ca734120a30c3677d596a5e3 (patch)
tree4f1dbdfd5667c01e510aa36de7fef582dadb1d8d /net
parent0c73680313e7e819718605acbcba19b46316044f (diff)
parentd932a867e9445a54e49ecbff4e07bb2d1d0197be (diff)
Merge pull request #24088 from TDT-AG/pr/20240506-net-tools
net-tools: add netstat utiltiy
Diffstat (limited to 'net')
-rw-r--r--net/net-tools/Makefile24
1 files changed, 23 insertions, 1 deletions
diff --git a/net/net-tools/Makefile b/net/net-tools/Makefile
index 306b0d5df..60ff0fb2d 100644
--- a/net/net-tools/Makefile
+++ b/net/net-tools/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=net-tools
PKG_VERSION:=2.10
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://sourceforge.net/projects/net-tools/files/
@@ -53,6 +53,22 @@ define Package/net-tools-route/description
functionality of the net-tools variant (e.g. AF_X25).
endef
+define Package/net-tools-netstat
+ SECTION:=net
+ CATEGORY:=Network
+ TITLE:=net-tools - netstat utility
+ URL:=http://net-tools.sourceforge.net/
+ PROVIDES:=route
+ ALTERNATIVES:=300:/bin/netstat:/usr/libexec/net-tools-netstat
+endef
+
+define Package/net-tools-netstat/description
+ Replace busybox version of the netstat command with the full net-tools
+ version. This is normally not needed as busybox is smaller and provides
+ sufficient functionality, but some users may want or need the full
+ functionality of the net-tools variant.
+endef
+
define Build/Configure
# Failed configure.sh leaves stub config.h around.
rm -f $(PKG_BUILD_DIR)/config.h
@@ -69,5 +85,11 @@ define Package/net-tools-route/install
$(INSTALL_BIN) $(PKG_BUILD_DIR)/route $(1)/usr/libexec/net-tools-route
endef
+define Package/net-tools-netstat/install
+ $(INSTALL_DIR) $(1)/usr/libexec
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/netstat $(1)/usr/libexec/net-tools-netstat
+endef
+
$(eval $(call BuildPackage,mii-tool))
$(eval $(call BuildPackage,net-tools-route))
+$(eval $(call BuildPackage,net-tools-netstat))