aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorMoritz Warning <moritzwarning@web.de>2018-04-12 17:41:42 +0200
committerMoritz Warning <moritzwarning@web.de>2018-04-12 23:20:21 +0200
commita0b12895dcd88435dc68c9619dc1b9fc6dcaeca6 (patch)
treeb1306d7402bcd26f06d094b2e6f2713320593a21 /net
parenteb16e06f8f4b6c72f746a5f718a360ae622f75cd (diff)
zerotier: disable -pie to avoid segfault
Signed-off-by: Moritz Warning <moritzwarning@web.de>
Diffstat (limited to 'net')
-rw-r--r--net/zerotier/patches/0005-remove-pie.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/net/zerotier/patches/0005-remove-pie.patch b/net/zerotier/patches/0005-remove-pie.patch
new file mode 100644
index 000000000..63f2efcba
--- /dev/null
+++ b/net/zerotier/patches/0005-remove-pie.patch
@@ -0,0 +1,26 @@
+From 14a8fe1f7cdef1f1e0c0842f6fedde154cf4ab57 Mon Sep 17 00:00:00 2001
+From: Moritz Warning <moritzwarning@web.de>
+Date: Thu, 12 Apr 2018 17:09:16 +0200
+Subject: [PATCH 5/5] remove -pie
+
+this prevents immediate segfault on start
+---
+ make-linux.mk | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/make-linux.mk b/make-linux.mk
+index f5b3d8df..8589e5d6 100644
+--- a/make-linux.mk
++++ b/make-linux.mk
+@@ -67,7 +67,7 @@ else
+ override CFLAGS+=-Wall -fPIE -pthread $(INCLUDES) -DNDEBUG $(DEFS)
+ CXXFLAGS?=-O3 -fstack-protector
+ override CXXFLAGS+=-Wall -Wno-unused-result -Wreorder -fPIE -std=c++11 -pthread $(INCLUDES) -DNDEBUG $(DEFS)
+- override LDFLAGS+=-pie -Wl,-z,relro,-z,now
++ override LDFLAGS+=-Wl,-z,relro,-z,now
+ STRIP?=strip
+ STRIP+=--strip-all
+ endif
+--
+2.16.3
+