aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorTed Hess <thess@kitschensync.net>2015-05-26 10:49:40 -0400
committerTed Hess <thess@kitschensync.net>2015-05-26 10:49:40 -0400
commit9589efa5bcd03731d5acf43b7e17085f16f61f70 (patch)
treea2f7e7892111a4b054be9c4e0cd3fd3ce01ce12e /net
parent1fac3a0c3a07a98f19e3beadab47116e6ac77047 (diff)
parent4a343362da5b7c54fcfa7b403a026c1a2fee0b88 (diff)
Merge pull request #1294 from mar-kolya/add-bridge-utils
Move bridge-utils from oldpackages
Diffstat (limited to 'net')
-rw-r--r--net/bridge-utils/Makefile52
-rw-r--r--net/bridge-utils/patches/001-libbridge_cflags.patch11
-rw-r--r--net/bridge-utils/patches/010-fix_struct_in6_addr_usage.patch10
3 files changed, 73 insertions, 0 deletions
diff --git a/net/bridge-utils/Makefile b/net/bridge-utils/Makefile
new file mode 100644
index 000000000..5a9cdb8af
--- /dev/null
+++ b/net/bridge-utils/Makefile
@@ -0,0 +1,52 @@
+#
+# Copyright (C) 2006-2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
+
+PKG_NAME:=bridge-utils
+PKG_VERSION:=1.5
+PKG_RELEASE:=3
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=https://git.kernel.org/pub/scm/linux/kernel/git/shemminger/bridge-utils.git
+PKG_SOURCE_VERSION:=v${PKG_VERSION}
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+
+PKG_LICENSE:=GPL-2.0+
+PKG_LICENSE_FILES:=COPYING
+PKG_FIXUP:=autoreconf
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/bridge
+ SECTION:=net
+ CATEGORY:=Base system
+ TITLE:=Ethernet bridging configuration utility
+ URL:=http://bridge.sourceforge.net/
+ PKG_MAINTAINER:=Nikolay Martynov <mar.kolya@gmail.com>
+endef
+
+define Package/bridge/description
+ Manage ethernet bridging: a way to connect networks together to
+ form a larger network.
+endef
+
+TARGET_CFLAGS += -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE
+
+CONFIGURE_ARGS += \
+ --with-linux-headers="$(LINUX_DIR)" \
+
+define Package/bridge/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/brctl/brctl $(1)/usr/sbin
+endef
+
+$(eval $(call BuildPackage,bridge))
diff --git a/net/bridge-utils/patches/001-libbridge_cflags.patch b/net/bridge-utils/patches/001-libbridge_cflags.patch
new file mode 100644
index 000000000..e35a64947
--- /dev/null
+++ b/net/bridge-utils/patches/001-libbridge_cflags.patch
@@ -0,0 +1,11 @@
+--- a/libbridge/Makefile.in
++++ b/libbridge/Makefile.in
+@@ -5,7 +5,7 @@ AR=ar
+ RANLIB=@RANLIB@
+
+ CC=@CC@
+-CFLAGS = -Wall -g $(KERNEL_HEADERS)
++CFLAGS = -Wall -g @CFLAGS@ $(KERNEL_HEADERS)
+
+ prefix=@prefix@
+ exec_prefix=@exec_prefix@
diff --git a/net/bridge-utils/patches/010-fix_struct_in6_addr_usage.patch b/net/bridge-utils/patches/010-fix_struct_in6_addr_usage.patch
new file mode 100644
index 000000000..c2087e590
--- /dev/null
+++ b/net/bridge-utils/patches/010-fix_struct_in6_addr_usage.patch
@@ -0,0 +1,10 @@
+--- a/libbridge/libbridge.h
++++ b/libbridge/libbridge.h
+@@ -20,6 +20,7 @@
+ #define _LIBBRIDGE_H
+
+ #include <sys/socket.h>
++#include <netinet/in.h>
+ #include <linux/if.h>
+ #include <linux/if_bridge.h>
+