aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorTiago Gaspar <tiagogaspar8@gmail.com>2019-10-01 01:59:36 +0100
committerTiago Gaspar <tiagogaspar8@gmail.com>2019-10-01 01:59:36 +0100
commit95307f2a4b3b64db9244f670f3ea2c7cf3cc2492 (patch)
tree3913477400088d301f26099ad489db8b658f42f9 /net
parent5de554a04ff1bdb0793a37f1dd8b3bfd15399574 (diff)
kea: fix and improve makefile
Fix an issue where the Makefile wouldn't allow kea to show up in the menuconfig Also added some description to the packages Signed-off-by: Tiago Gaspar <tiagogaspar8@gmail.com>
Diffstat (limited to 'net')
-rw-r--r--net/kea/Makefile78
1 files changed, 62 insertions, 16 deletions
diff --git a/net/kea/Makefile b/net/kea/Makefile
index d52a159a4..0f6c2b1ae 100644
--- a/net/kea/Makefile
+++ b/net/kea/Makefile
@@ -39,6 +39,13 @@ define Package/kea/Default
URL:=https://www.isc.org/kea
endef
+
+###### *************************************************************************
+define Package/kea
+ $(call Package/kea/Default)
+ TITLE+=ISC Kea
+endef
+# shown in LuCI package description
define Package/kea/description
Kea is an open source DHCPv4/DHCPv6 server being developed by Internet
Systems Consortium. Kea is a high-performance, extensible DHCP server
@@ -48,56 +55,95 @@ define Package/kea/description
management REST interface, and a DHCP benchmarking tool, perfdhcp.
endef
+###### *************************************************************************
define Package/kea-libs
$(call Package/kea/Default)
- TITLE+= Libraries
+ TITLE+=Libraries
DEPENDS:=+libopenssl +log4cplus \
- +boost +boost-python3 +boost-system
+ +boost +boost-python3 +boost-system
+endef
+define Package/kea-libs/description
+ Kea required Libraries.
+endef
+
+###### *************************************************************************
+define Package/kea-ctrl
+ $(call Package/kea/Default)
+ TITLE+=Control
+ DEPENDS:=+kea-dhcp4 \
+ +IPV6:kea-dhcp6 +kea-dhcp-ddns
+endef
+define Package/kea-ctrl/description
+ Tool to start, stop, reconfigure, and report status for the Kea servers.
endef
+###### *************************************************************************
define Package/kea-dhcp4
$(call Package/kea/Default)
- TITLE+= DHCP Server v4
+ TITLE+=DHCP Server v4
DEPENDS:=+kea-libs
endef
+define Package/kea-dhcp4/description
+ The DHCPv4 server process. This process responds to DHCPv4 queries from clients.
+endef
+###### *************************************************************************
define Package/kea-dhcp6
$(call Package/kea/Default)
- TITLE+= DHCP Server v6
+ TITLE+=DHCP Server v6
DEPENDS:=@IPV6 +kea-libs
endef
+define Package/kea-dhcp6/description
+ The DHCPv6 server process. This process responds to DHCPv6 queries from clients.
+endef
+###### *************************************************************************
define Package/kea-dhcp-ddns
$(call Package/kea/Default)
- TITLE+= DHCP - DDNS
+ TITLE+=DHCP Dynamic DNS
DEPENDS:=+kea-libs
endef
+define Package/kea-dhcp-ddns/description
+ The DHCP Dynamic DNS process. This process acts as an intermediary between
+the DHCP servers and DNS servers. It receives name update requests from the
+DHCP servers and sends DNS Update messages to the DNS servers.
+endef
+###### *************************************************************************
define Package/kea-admin
$(call Package/kea/Default)
- TITLE+= Admin
- DEPENDS:= +kea-libs
+ TITLE+=Admin
+ DEPENDS:=+kea-libs
endef
-
-define Package/kea-ctrl
- $(call Package/kea/Default)
- TITLE+= Control
- DEPENDS:= +kea-dhcp4 +IPV6:kea-dhcp6 \
- +kea-dhcp-ddns
+define Package/kea-admin/description
+ A useful tool for database backend maintenance (creating a new database,
+checking versions, upgrading etc.).
endef
+##### *************************************************************************
define Package/kea-lfc
$(call Package/kea/Default)
- TITLE+= lfc
+ TITLE+=lfc
DEPENDS:=+kea-libs
endef
+define Package/kea-lfc/description
+ This process removes redundant information from the files used to provide
+persistent storage for the memfile data base backend. While it can be run
+standalone, it is normally run as and when required by the Kea DHCP servers.
+endef
+##### *************************************************************************
define Package/kea-perfdhcp
$(call Package/kea/Default)
- TITLE+= perfdhcp
+ TITLE+=perfdhcp (Benchmarking)
DEPENDS:=+kea-libs
endef
+define Package/kea-perfdhcp/description
+ A DHCP benchmarking tool which simulates multiple clients to test both
+DHCPv4 and DHCPv6 server performance.
+endef
+###### *************************************************************************
HOST_CONFIGURE_ARGS += \
--with-boost-include="$(STAGING_DIR_HOSTPKG)" \
--with-log4cplus="$(STAGING_DIR_HOSTPKG)" \
@@ -198,10 +244,10 @@ endef
$(eval $(call HostBuild))
$(eval $(call BuildPackage,kea-libs))
+$(eval $(call BuildPackage,kea-ctrl))
$(eval $(call BuildPackage,kea-dhcp4))
$(eval $(call BuildPackage,kea-dhcp6))
$(eval $(call BuildPackage,kea-dhcp-ddns))
$(eval $(call BuildPackage,kea-admin))
-$(eval $(call BuildPackage,kea-ctrl))
$(eval $(call BuildPackage,kea-lfc))
$(eval $(call BuildPackage,kea-perfdhcp))