aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorTianling Shen <cnsztl@immortalwrt.org>2021-04-27 19:42:41 +0800
committerTianling Shen <cnsztl@immortalwrt.org>2021-04-27 20:34:18 +0800
commit92efcc295648e9c16f3fb2d183019be9e275c3ea (patch)
tree41bb3998f17fbaae0fbb8f2510c84c665d96c96c /net
parent816c41b6fcabfefea36f98568477cd06e74be386 (diff)
xray-core: remove PROVIDES
Xray now is no longer planning to keep compatibility with original v2ray. Remove PROVIDES before it is totally broken. Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
Diffstat (limited to 'net')
-rw-r--r--net/xray-core/Makefile4
-rw-r--r--net/xray-core/files/config.json.example2
2 files changed, 2 insertions, 4 deletions
diff --git a/net/xray-core/Makefile b/net/xray-core/Makefile
index 1264dc9a7..0db91efa3 100644
--- a/net/xray-core/Makefile
+++ b/net/xray-core/Makefile
@@ -37,7 +37,6 @@ endef
define Package/xray-core
$(call Package/xray/template)
DEPENDS:=$(GO_ARCH_DEPENDS) +ca-bundle
- PROVIDES:=v2ray-core
endef
define Package/xray-example
@@ -55,7 +54,7 @@ define Package/xray-geodata
endef
define Package/xray/description
- Xray, Penetrates Everything. Also the best v2ray-core, with XTLS support. Fully compatible configuration.
+ Xray, Penetrates Everything. It helps you to build your own computer network.
It secures your network connections and thus protects your privacy.
endef
@@ -112,7 +111,6 @@ define Package/xray-core/install
$(call GoPackage/Package/Install/Bin,$(PKG_INSTALL_DIR))
$(INSTALL_DIR) $(1)/usr/bin/
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/main $(1)/usr/bin/xray
- $(LN) xray $(1)/usr/bin/v2ray
$(INSTALL_DIR) $(1)/etc/xray/
$(INSTALL_CONF) $(CURDIR)/files/config.json.example $(1)/etc/xray/
diff --git a/net/xray-core/files/config.json.example b/net/xray-core/files/config.json.example
index 52597f587..710bb1bec 100644
--- a/net/xray-core/files/config.json.example
+++ b/net/xray-core/files/config.json.example
@@ -1,6 +1,6 @@
// Config file of Xray. This file follows standard JSON format, with comments support.
// Uncomment entries below to satisfy your needs. Also read our manual for more detail at
-// https://www.v2fly.org/en_US/config/overview.html and https://xray.sh/en/config/
+// https://xtls.github.io/en/config/
{
"log": {
// By default, Xray writes access log to stdout.