aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorMichael Heimpold <mhei@heimpold.de>2023-10-29 21:51:27 +0100
committerMichael Heimpold <mhei@heimpold.de>2023-10-29 21:51:27 +0100
commit91fe351a2d69483dbe0b38526a02a534e0edc234 (patch)
treedcb0adb8c16fb597f24b4adf21b8899051cb865e /net
parente8914a2a5762392f444afb9bbe86b429cda4ca29 (diff)
gensio: update to 2.7.6
Also disable probably rarely used features to lower the library footprint. Signed-off-by: Michael Heimpold <mhei@heimpold.de>
Diffstat (limited to 'net')
-rw-r--r--net/gensio/Makefile24
-rw-r--r--net/gensio/patches/100-musl-compat.patch11
2 files changed, 19 insertions, 16 deletions
diff --git a/net/gensio/Makefile b/net/gensio/Makefile
index b193a0492..6fca78e9c 100644
--- a/net/gensio/Makefile
+++ b/net/gensio/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=gensio
-PKG_VERSION:=2.4.2
+PKG_VERSION:=2.7.6
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/ser2net
-PKG_HASH:=2593c1e7beaec3a0a4acbf60f94bbf64b99883d86f172a3b584eba5f67441b4b
+PKG_HASH:=7574fb710ddd6580d53ea44af4ddfc57f28dbcdc646d842f7ed8ccc1235fdf89
PKG_LICENSE:=GPL-2.0-or-later
PKG_LICENSE_FILES:=COPYING
@@ -39,15 +39,25 @@ include $(INCLUDE_DIR)/package.mk
include ../../lang/python/python3-package.mk
CONFIGURE_ARGS += \
+ --$(if $(CONFIG_GENSIO_AVAHI),with,without)-avahi \
--$(if $(CONFIG_GENSIO_SSL),with,without)-openssl \
--$(if $(CONFIG_GENSIO_SCTP),with,without)-sctp \
--$(if $(CONFIG_GENSIO_WRAP),with,without)-tcp-wrappers \
--$(if $(CONFIG_GENSIO_PTHREADS),with,without)-pthreads \
--$(if $(CONFIG_GENSIO_GLIB),with,without)-glib \
--$(if $(CONFIG_GENSIO_TCL),with,without)-tcl \
+ --without-afskmdm \
+ --without-ax25 \
+ --without-alsa \
--without-go \
+ --without-ipmisol \
+ --without-kiss \
--without-openipmi \
+ --without-portaudio \
+ --without-sound \
--with-cplusplus \
+ --with-flock-locking \
+ --with-uucp-locking \
--disable-doc
CONFIGURE_VARS += \
@@ -161,8 +171,9 @@ endef
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include/gensio/
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/include/gensio/* $(1)/usr/include/gensio/
- $(INSTALL_DIR) $(1)/usr/lib/
+ $(INSTALL_DIR) $(1)/usr/lib/gensio
$(CP) $(PKG_INSTALL_DIR)/usr/lib/*.{so*,a,la} $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/gensio/* $(1)/usr/lib/gensio/
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig/
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/* $(1)/usr/lib/pkgconfig/
ifneq ($(CONFIG_PACKAGE_python3-gensio),)
@@ -173,8 +184,11 @@ endif
endef
define Package/libgensio/install
- $(INSTALL_DIR) $(1)/usr/lib
+ $(INSTALL_DIR) $(1)/usr/lib/gensio
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libgensio.so.* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgensioosh.so.* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgensiomdns.so.* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/gensio/* $(1)/usr/lib/gensio/
ifeq ($(CONFIG_GENSIO_GLIB),y)
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libgensioglib.so.* $(1)/usr/lib/
endif
@@ -200,7 +214,7 @@ endef
define Package/libgensiocpp/install
$(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgensiocpp.so.* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgensio*cpp.so.* $(1)/usr/lib/
endef
$(eval $(call BuildPackage,libgensio))
diff --git a/net/gensio/patches/100-musl-compat.patch b/net/gensio/patches/100-musl-compat.patch
deleted file mode 100644
index da61fe741..000000000
--- a/net/gensio/patches/100-musl-compat.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/tools/gensiotool.c
-+++ b/tools/gensiotool.c
-@@ -44,7 +44,7 @@
- #include <signal.h>
- #include <errno.h>
- #include <sys/types.h>
--#include <sys/unistd.h>
-+#include <unistd.h>
- #include <syslog.h>
- #endif
-