aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@savoirfairelinux.com>2019-02-14 13:30:58 -0500
committerMaxim Cournoyer <maxim.cournoyer@savoirfairelinux.com>2019-02-14 13:34:39 -0500
commit90a713e3c6c33a38b53dcbcc1abec4801bc86ce5 (patch)
tree72a3cd26e9e209f428fdcbec3161d48629eefd3f /net
parentc82e79713c63caced1efa29d794c0694423530da (diff)
net-snmp: disable support for perl
Using an external toolchain, it was discovered that net-snmp would link with the Perl library (-lperl) from the host rather than from the target. Since we do not provide Perl as a dependency to net-snmp, the solution is to disable support for it. Fixes issue #8217. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@savoirfairelinux.com>
Diffstat (limited to 'net')
-rw-r--r--net/net-snmp/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/net/net-snmp/Makefile b/net/net-snmp/Makefile
index 8fa011523..6e452d3c8 100644
--- a/net/net-snmp/Makefile
+++ b/net/net-snmp/Makefile
@@ -206,6 +206,9 @@ CONFIGURE_ARGS += \
--without-zlib \
--with-nl \
$(call autoconf_bool,CONFIG_IPV6,ipv6) \
+ --disable-perl-cc-checks \
+ --disable-embedded-perl \
+ --without-perl-modules
CONFIGURE_VARS += \
ac_cv_header_netlink_netlink_h=yes \