aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorSergey Ponomarev <stokito@gmail.com>2023-12-03 18:14:42 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2024-05-06 13:44:08 +0200
commit8aadb12835bd109399e687bb5a15a7de17f5a151 (patch)
treea65fca448df6e10bcda980f215c1ee4658ebcac2 /net
parent072140981093c20e1e4716a71249ff824cb79e9a (diff)
openssh-keygen: Make ssh-keygen as an alternative to dropbearkey
The DropBear's dropbearkey tool is compatible with OpenSSH ssh-keygen. It was set by default as the /usr/bin/ssh-keygen program since the PR https://github.com/openwrt/openwrt/pull/14174 Now if a user need for a full ssh-keygen the openssh-keygen package should substitute it gracefully as an alternative. Signed-off-by: Sergey Ponomarev <stokito@gmail.com> Link: https://github.com/openwrt/packages/pull/22861 [ wrap to 80 columns ] Link: https://github.com/openwrt/packages/pull/22861 Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
Diffstat (limited to 'net')
-rw-r--r--net/openssh/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/net/openssh/Makefile b/net/openssh/Makefile
index 450ab5ff8..dd5c17939 100644
--- a/net/openssh/Makefile
+++ b/net/openssh/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=openssh
PKG_VERSION:=9.7p1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://cdn.openbsd.org/pub/OpenBSD/OpenSSH/portable/ \
@@ -81,6 +81,7 @@ define Package/openssh-keygen
$(call Package/openssh/Default)
DEPENDS+= +libopenssl +zlib
TITLE+= keygen
+ ALTERNATIVES:=200:/usr/bin/ssh-keygen:/usr/libexec/ssh-keygen-openssh
endef
define Package/openssh-keygen/description
@@ -221,8 +222,8 @@ define Package/openssh-client-utils/install
endef
define Package/openssh-keygen/install
- $(INSTALL_DIR) $(1)/usr/bin
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/ssh-keygen $(1)/usr/bin/
+ $(INSTALL_DIR) $(1)/usr/libexec
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/ssh-keygen $(1)/usr/libexec/ssh-keygen-openssh
endef
define Package/openssh-server/install