aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorAlberto Martinez-Alvarez <amteza@gmail.com>2022-08-15 10:53:14 +1000
committerRosen Penev <rosenp@gmail.com>2022-08-16 13:09:50 -0700
commit859971a3aeeead6c1764844d3fdaa0589d49aba3 (patch)
treec57357986af8f4eb7f5e89bb2f65e0680f8e4fa9 /net
parent6c757f0ff82b6f640c599425ea87ee1ca2e6685c (diff)
iperf: Updated to 2.1.8
Enabling fast sampling to support four digit (e.g., 1.0000) precision in reports' timestamps. Useful for sub-millisecond sampling. Changelog: https://sourceforge.net/p/iperf2/code/ci/2-1-8/tree/README Signed-off-by: Alberto Martinez-Alvarez <amteza@gmail.com> Maintainer: @nbd168 Compile tested: ath79, ramips, bcm27xx
Diffstat (limited to 'net')
-rw-r--r--net/iperf/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/net/iperf/Makefile b/net/iperf/Makefile
index d071d0c03..3c320bff7 100644
--- a/net/iperf/Makefile
+++ b/net/iperf/Makefile
@@ -8,11 +8,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=iperf
-PKG_VERSION:=2.1.3
+PKG_VERSION:=2.1.8
PKG_RELEASE:=$(AUTORELEASE)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_HASH:=dfe2197e2842fe9c9d9677bf1cb20a5a9ccfcb9a9de79f9927c39f73204ba003
+PKG_HASH:=8e2cf2fbc9d0d4d1cf9d109b1e328459f9622993dc9a4c5a7dc8a2088fb7beaf
PKG_SOURCE_URL:=@SF/iperf2
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
@@ -45,6 +45,7 @@ define Package/iperf/config
endef
CONFIGURE_ARGS += \
+ --enable-fastsampling \
$(call autoconf_bool,CONFIG_IPERF_ENABLE_MULTICAST,multicast) \
$(call autoconf_bool,CONFIG_IPV6,ipv6)