aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-07-21 11:35:46 -0700
committerRosen Penev <rosenp@gmail.com>2019-07-22 12:06:59 -0700
commit84c92f215d973f18ecb8d832dc8a244a6a7e3f89 (patch)
tree9a3665aa84cac9e7e6386832dff430219cea5f63 /net
parent46dabcf89bf867a45ceb8ffecc25a7432439a0d7 (diff)
rtorrent: Update to 0.9.8
Switch to codeload. A lot simpler. Remove upstreamed patch. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'net')
-rw-r--r--net/rtorrent/Makefile13
-rw-r--r--net/rtorrent/patches/100-fix-cross_compile.patch20
2 files changed, 8 insertions, 25 deletions
diff --git a/net/rtorrent/Makefile b/net/rtorrent/Makefile
index c6a5006ea..1b23c5ba8 100644
--- a/net/rtorrent/Makefile
+++ b/net/rtorrent/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=rtorrent
-PKG_VERSION:=0.9.7
-PKG_RELEASE:=2
+PKG_VERSION:=0.9.8
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://github.com/rakshasa/rtorrent/releases/download/v$(PKG_VERSION)
-PKG_HASH:=5d9842fe48c9582fbea2c7bf9f51412c1ccbba07d059b257039ad53b863fe8bb
+PKG_SOURCE_URL:=https://codeload.github.com/rakshasa/rtorrent/tar.gz/v$(PKG_VERSION)?
+PKG_HASH:=bc889ce1dde475ec56aa72ae996912ff58723226a4f4256fef4f1f8636d991d4
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
PKG_MAINTAINER:=Rosen Penev <rosenp@gmail.com>
@@ -23,6 +23,7 @@ PKG_LICENSE_FILES:=COPYING
PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
PKG_BUILD_PARALLEL:=1
+PKG_REMOVE_FILES:=autogen.sh
include $(INCLUDE_DIR)/package.mk
@@ -32,7 +33,7 @@ define Package/rtorrent/Default
CATEGORY:=Network
TITLE:=BitTorrent client for ncurses
URL:=https://github.com/rakshasa/rtorrent
- DEPENDS:=+libcurl +libtorrent +libncurses +libsigcxx +libpthread
+ DEPENDS:=+libcurl +libtorrent +libncurses +libpthread
endef
define Package/rtorrent/Default/description
@@ -76,6 +77,8 @@ ifeq ($(BUILD_VARIANT),rpc)
CONFIGURE_ARGS += --with-xmlrpc-c
endif
+TARGET_CXXFLAGS += -faligned-new
+
define Package/rtorrent/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/rtorrent $(1)/usr/bin/
diff --git a/net/rtorrent/patches/100-fix-cross_compile.patch b/net/rtorrent/patches/100-fix-cross_compile.patch
deleted file mode 100644
index 50657df13..000000000
--- a/net/rtorrent/patches/100-fix-cross_compile.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/scripts/common.m4
-+++ b/scripts/common.m4
-@@ -153,7 +153,7 @@ dnl Need to fix this so that it uses t
- AC_DEFUN([TORRENT_CHECK_EXECINFO], [
- AC_MSG_CHECKING(for execinfo.h)
-
-- AC_RUN_IFELSE([AC_LANG_SOURCE([
-+ AC_LINK_IFELSE([AC_LANG_SOURCE([
- #include <execinfo.h>
- int main() { backtrace((void**)0, 0); backtrace_symbols((char**)0, 0); return 0;}
- ])],
-@@ -168,7 +168,7 @@ AC_DEFUN([TORRENT_CHECK_EXECINFO], [
- AC_DEFUN([TORRENT_CHECK_ALIGNED], [
- AC_MSG_CHECKING(the byte alignment)
-
-- AC_RUN_IFELSE([AC_LANG_SOURCE([
-+ AC_LINK_IFELSE([AC_LANG_SOURCE([
- #include <inttypes.h>
- int main() {
- char buf@<:@8@:>@ = { 0, 0, 0, 0, 1, 0, 0, 0 };