aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2015-05-23 18:28:17 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2015-05-24 15:27:50 +0200
commit84c6815a9c6ba7224c3f94bf3d63645cad7a78d2 (patch)
tree0b781e12b9266d8478f7b22debd06453e6073881 /net
parent59f33d2aa7da968294ee1ccdd1336dd7d7d76837 (diff)
openvswitch: fix build with kernel >= 3.18.13
This fixes a build problem with kernel >= 3.18.13. This should close #1283. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'net')
-rw-r--r--net/openvswitch/Makefile2
-rw-r--r--net/openvswitch/patches/0003-datapath-do-not-add-vlan_hwaccel_push_inside-for-ker.patch35
2 files changed, 36 insertions, 1 deletions
diff --git a/net/openvswitch/Makefile b/net/openvswitch/Makefile
index eb37696da..08c65be1c 100644
--- a/net/openvswitch/Makefile
+++ b/net/openvswitch/Makefile
@@ -11,7 +11,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=openvswitch
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_VERSION:=2.3.90
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_LICENSE:=Apache-2.0
diff --git a/net/openvswitch/patches/0003-datapath-do-not-add-vlan_hwaccel_push_inside-for-ker.patch b/net/openvswitch/patches/0003-datapath-do-not-add-vlan_hwaccel_push_inside-for-ker.patch
new file mode 100644
index 000000000..673b8d6b5
--- /dev/null
+++ b/net/openvswitch/patches/0003-datapath-do-not-add-vlan_hwaccel_push_inside-for-ker.patch
@@ -0,0 +1,35 @@
+From 5919cb26c631b1dd77a745a3c546f9d117ed34b3 Mon Sep 17 00:00:00 2001
+From: Hauke Mehrtens <hauke@hauke-m.de>
+Date: Sat, 23 May 2015 18:12:09 +0200
+Subject: [PATCH] datapath: do not add vlan_hwaccel_push_inside() for kernel >=
+ 3.18.13
+
+The vlan_hwaccel_push_inside() function was backported in this commit
+to kernel 3.18.13:
+
+commit a67e2e88342accd49587d9bad72f6dabd7673f7c
+Author: Jiri Pirko <jiri@resnulli.us>
+Date: Wed Nov 19 14:04:59 2014 +0100
+
+ vlan: introduce *vlan_hwaccel_push_inside helpers
+
+ [ Upstream commit 5968250c868ceee680aa77395b24e6ddcae17d36 ]
+
+Without this patch compilation breaks on kernel >= 3.18.13
+
+Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
+---
+ datapath/linux/compat/include/linux/if_vlan.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/datapath/linux/compat/include/linux/if_vlan.h
++++ b/datapath/linux/compat/include/linux/if_vlan.h
+@@ -52,7 +52,7 @@ static inline struct sk_buff *rpl_vlan_i
+ }
+ #endif
+
+-#if LINUX_VERSION_CODE < KERNEL_VERSION(3,19,0)
++#if LINUX_VERSION_CODE < KERNEL_VERSION(3,18,13)
+ /*
+ * __vlan_hwaccel_push_inside - pushes vlan tag to the payload
+ * @skb: skbuff to tag