aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-07-14 16:57:12 -0700
committertripolar <tripolar@users.noreply.github.com>2019-07-21 12:30:52 +0200
commit80bad7073f15e8b9c6567463d3f42a7121e35601 (patch)
tree31ddd9c197b5838088413f6886cf588b11186961 /net
parent640ae6efed38194b6904bd02270b4db7aead4cf4 (diff)
etherwake: Remove obsolete uClibc patch
No such issue with uClibc-ng. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'net')
-rw-r--r--net/etherwake/Makefile2
-rw-r--r--net/etherwake/patches/100-no_ether_hostton.patch37
2 files changed, 1 insertions, 38 deletions
diff --git a/net/etherwake/Makefile b/net/etherwake/Makefile
index 9a0b9ba80..98063c036 100644
--- a/net/etherwake/Makefile
+++ b/net/etherwake/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=etherwake
PKG_VERSION:=1.09
-PKG_RELEASE:=4
+PKG_RELEASE:=5
PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/e/etherwake
diff --git a/net/etherwake/patches/100-no_ether_hostton.patch b/net/etherwake/patches/100-no_ether_hostton.patch
deleted file mode 100644
index e33c06b11..000000000
--- a/net/etherwake/patches/100-no_ether_hostton.patch
+++ /dev/null
@@ -1,37 +0,0 @@
---- etherwake-1.09.orig/ether-wake.c 2005-07-10 20:44:25.000000000 +0200
-+++ etherwake-1.09.orig.no_ether_hostton/ether-wake.c 2007-04-29 19:03:41.000000000 +0200
-@@ -15,7 +15,11 @@
- " an optional password appended.\n"
- "\n"
- " The single required parameter is the Ethernet MAC (station) address\n"
-+#if !defined(__UCLIBC__)
- " of the machine to wake or a host ID with known NSS 'ethers' entry.\n"
-+#else
-+" of the machine to wake.\n"
-+#endif
- " The MAC address may be found with the 'arp' program while the target\n"
- " machine is awake.\n"
- "\n"
-@@ -289,16 +293,22 @@
- if (debug)
- fprintf(stderr, "The target station address is %s.\n",
- ether_ntoa(eaddr));
-+#if !defined(__UCLIBC__)
- } else if (ether_hostton(hostid, eaddr) == 0) {
- if (debug)
- fprintf(stderr, "Station address for hostname %s is %s.\n",
- hostid, ether_ntoa(eaddr));
-+#endif
- } else {
- (void)fprintf(stderr,
- "ether-wake: The Magic Packet host address must be "
- "specified as\n"
-+#if !defined(__UCLIBC__)
- " - a station address, 00:11:22:33:44:55, or\n"
- " - a hostname with a known 'ethers' entry.\n");
-+#else
-+ " - a station address, 00:11:22:33:44:55\n");
-+#endif
- return -1;
- }
- return 0;