aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorEneas U de Queiroz <cotequeiroz@gmail.com>2023-02-09 15:05:30 -0300
committerEneas U de Queiroz <cotequeiroz@gmail.com>2023-02-16 10:28:52 -0300
commit78dcc29e47079b6f5aad917dcdf935325b5e4fdf (patch)
treec2701617d666c74922255c47a90baca60cd4a003 /net
parent94b06478ed6d2c20b75b2dc5eb81e0de2cdb98c5 (diff)
squid: bump to release 5.7
This is the latest version and brings compatibility with OpenSSL 3.0. Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
Diffstat (limited to 'net')
-rw-r--r--net/squid/Makefile10
-rw-r--r--net/squid/patches/001-glibc-compile.patch12
-rw-r--r--net/squid/patches/010-no-buildcxxflags.patch (renamed from net/squid/patches/010-no-buildbxxflags.patch)2
-rw-r--r--net/squid/patches/020-libxml-drop-xmlSetFeature.patch10
4 files changed, 6 insertions, 28 deletions
diff --git a/net/squid/Makefile b/net/squid/Makefile
index f55dcf841..79299e0b7 100644
--- a/net/squid/Makefile
+++ b/net/squid/Makefile
@@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=squid
-PKG_VERSION:=4.17
-PKG_RELEASE:=$(AUTORELEASE)
+PKG_VERSION:=5.7
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
-PKG_SOURCE_URL:=http://www2.pl.squid-cache.org/Versions/v4/ \
- http://www.squid-cache.org/Versions/v4/
-PKG_HASH:=cb928ac08c7c86b151b1c8f827abe1a84d83181a2a86e0d512286163e1e31418
+PKG_SOURCE_URL:=http://www2.pl.squid-cache.org/Versions/v5/ \
+ http://www.squid-cache.org/Versions/v5/
+PKG_HASH:=6b0753aaba4c9c4efd333e67124caecf7ad6cc2d38581f19d2f0321f5b7ecd81
PKG_MAINTAINER:=Marko Ratkaj <markoratkaj@gmail.com>
PKG_LICENSE:=GPL-2.0-or-later
diff --git a/net/squid/patches/001-glibc-compile.patch b/net/squid/patches/001-glibc-compile.patch
deleted file mode 100644
index fd11e85ce..000000000
--- a/net/squid/patches/001-glibc-compile.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/src/tools.cc
-+++ b/src/tools.cc
-@@ -582,7 +582,8 @@ enter_suid(void)
- }
- #else
-
-- setuid(0);
-+ if (setuid(0) < 0)
-+ debugs(50, 1, "no_suid: setuid (0)");
- #endif
- #if HAVE_PRCTL && defined(PR_SET_DUMPABLE)
- /* Set Linux DUMPABLE flag */
diff --git a/net/squid/patches/010-no-buildbxxflags.patch b/net/squid/patches/010-no-buildcxxflags.patch
index 163248545..c5a5eb61b 100644
--- a/net/squid/patches/010-no-buildbxxflags.patch
+++ b/net/squid/patches/010-no-buildcxxflags.patch
@@ -1,6 +1,6 @@
--- a/src/Makefile.am
+++ b/src/Makefile.am
-@@ -765,7 +765,7 @@ cache_cf.o: cf_parser.cci
+@@ -761,7 +761,7 @@ cache_cf.o: cf_parser.cci
# cf_gen builds the configuration files.
cf_gen$(EXEEXT): $(cf_gen_SOURCES) $(cf_gen_DEPENDENCIES) cf_gen_defines.cci
diff --git a/net/squid/patches/020-libxml-drop-xmlSetFeature.patch b/net/squid/patches/020-libxml-drop-xmlSetFeature.patch
deleted file mode 100644
index 02be06ab0..000000000
--- a/net/squid/patches/020-libxml-drop-xmlSetFeature.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/src/esi/Libxml2Parser.cc
-+++ b/src/esi/Libxml2Parser.cc
-@@ -91,7 +91,6 @@ ESILibxml2Parser::ESILibxml2Parser(ESIPa
-
- /* TODO: grab the document encoding from the headers */
- parser = xmlCreatePushParserCtxt(&sax, static_cast<void *>(this), NULL, 0, NULL);
-- xmlSetFeature(parser, "substitute entities", 0);
-
- if (entity_doc == NULL)
- entity_doc = htmlNewDoc(NULL, NULL);