aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorStan Grishin <stangri@melmac.ca>2022-12-10 05:32:20 +0000
committerStan Grishin <stangri@melmac.ca>2022-12-10 05:32:20 +0000
commit75ac50ca895e9e042afe9c4a64a367e3863e471f (patch)
tree433c081c51f8d662cf3b6a5c2b1ea62719945320 /net
parent39ddb150382687e1e9a0573893f59cd8ca6764ba (diff)
https-dns-proxy: fix restart
Signed-off-by: Stan Grishin <stangri@melmac.ca>
Diffstat (limited to 'net')
-rw-r--r--net/https-dns-proxy/Makefile2
-rwxr-xr-xnet/https-dns-proxy/files/https-dns-proxy.init2
2 files changed, 2 insertions, 2 deletions
diff --git a/net/https-dns-proxy/Makefile b/net/https-dns-proxy/Makefile
index a91a3d1cd..4b519a9b2 100644
--- a/net/https-dns-proxy/Makefile
+++ b/net/https-dns-proxy/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=https-dns-proxy
PKG_VERSION:=2022-10-15
-PKG_RELEASE:=9
+PKG_RELEASE:=10
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/aarond10/https_dns_proxy/
diff --git a/net/https-dns-proxy/files/https-dns-proxy.init b/net/https-dns-proxy/files/https-dns-proxy.init
index 201ddadc7..0e75a14d7 100755
--- a/net/https-dns-proxy/files/https-dns-proxy.init
+++ b/net/https-dns-proxy/files/https-dns-proxy.init
@@ -280,7 +280,7 @@ service_triggers() {
service_started() { procd_set_config_changed firewall; }
service_stopped() { procd_set_config_changed firewall; }
-restart() { procd_send_signal "$packageName"; }
+restart() { procd_send_signal "$packageName"; rc_procd start_service; }
dnsmasq_doh_server() {
local cfg="$1" param="$2" address="${3:-127.0.0.1}" port="$4" i