aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-05-31 14:33:23 -0700
committerGitHub <noreply@github.com>2020-05-31 14:33:23 -0700
commit73ba5683144b20d8755992f41646f9d9ec881dd8 (patch)
treee57c7085adb340d47f8906980949276b582c0c1b /net
parent1a5e41ba27999cf832a686efabb15ef295e81d79 (diff)
parent4cb5aa57fddb83e340cfadcfbeb93a7e340ce724 (diff)
Merge pull request #12281 from dl12345/bind
bind: add nslookup alternative to busybox nslookup
Diffstat (limited to 'net')
-rw-r--r--net/bind/Makefile16
1 files changed, 15 insertions, 1 deletions
diff --git a/net/bind/Makefile b/net/bind/Makefile
index 8726baa28..d114e5869 100644
--- a/net/bind/Makefile
+++ b/net/bind/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=bind
PKG_VERSION:=9.16.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
USERID:=bind=57:bind=57
PKG_MAINTAINER:=Noah Meyerhans <frodo@morgul.net>
@@ -83,6 +83,7 @@ define Package/bind-tools
DEPENDS:= \
+bind-check \
+bind-dig \
+ +bind-nslookup \
+bind-dnssec \
+bind-host \
+bind-rndc
@@ -113,6 +114,13 @@ define Package/bind-dig
TITLE+= DNS excavation tool
endef
+define Package/bind-nslookup
+ $(call Package/bind/Default)
+ TITLE+= nslookup utility
+ ALTERNATIVES:= \
+ 200:/usr/bin/nslookup:/usr/libexec/nslookup-bind
+endef
+
export BUILD_CC="$(TARGET_CC)"
TARGET_LDFLAGS += -Wl,--gc-sections,--as-needed
@@ -234,6 +242,11 @@ define Package/bind-dig/install
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/dig $(1)/usr/bin/
endef
+define Package/bind-nslookup/install
+ $(INSTALL_DIR) $(1)/usr/libexec
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/nslookup $(1)/usr/libexec/nslookup-bind
+endef
+
$(eval $(call BuildPackage,bind-libs))
$(eval $(call BuildPackage,bind-server))
$(eval $(call BuildPackage,bind-server-filter-aaaa))
@@ -244,3 +257,4 @@ $(eval $(call BuildPackage,bind-check))
$(eval $(call BuildPackage,bind-dnssec))
$(eval $(call BuildPackage,bind-host))
$(eval $(call BuildPackage,bind-dig))
+$(eval $(call BuildPackage,bind-nslookup))