aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorAlexander Ryzhov <github@ryzhov-al.ru>2015-04-23 13:52:50 +0000
committerAlexander Ryzhov <github@ryzhov-al.ru>2015-05-21 06:13:35 +0000
commit7343322bd09d898b55cf69cddb7fa434c3da9e00 (patch)
treeffd14c83f08e24626f8047515b510d505418c368 /net
parentb0f2853135188c59378785996d446bc72597a4d1 (diff)
rtorrent: respect IPv6 settings
Signed-off-by: Alexander Ryzhov <openwrt@ryzhov-al.ru>
Diffstat (limited to 'net')
-rw-r--r--net/rtorrent/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/net/rtorrent/Makefile b/net/rtorrent/Makefile
index af644100d..bba6ddee0 100644
--- a/net/rtorrent/Makefile
+++ b/net/rtorrent/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=rtorrent
-PKG_VERSION:=0.9.4-git-0
+PKG_VERSION:=0.9.4-git-1
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
@@ -72,7 +72,8 @@ TARGET_LDFLAGS += -lz -lpthread -Wl,-rpath-link=$(STAGING_DIR)/usr/lib
CONFIGURE_ARGS+= \
--enable-shared \
--disable-static \
- --disable-debug
+ --disable-debug \
+ $(call autoconf_bool,CONFIG_IPV6,ipv6)
ifeq ($(BUILD_VARIANT),rpc)
CONFIGURE_ARGS += \