aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-08-12 13:09:47 -0700
committerGitHub <noreply@github.com>2020-08-12 13:09:47 -0700
commit720b5117fb1b45e5043824ed381b210bf20d2b5f (patch)
treead698d2dadf17d810c6391606d81958e9331495d /net
parent02a5a7954296aa0ff93848238b2f69bd795f0b37 (diff)
parentdf6c468a5af6cf6f1799233f3e0b62dfbc34a6ec (diff)
Merge pull request #13079 from neheb/oor
oor: fix compilation with GCC 10
Diffstat (limited to 'net')
-rw-r--r--net/oor/Makefile5
-rw-r--r--net/oor/patches/010-gcc10.patch26
2 files changed, 28 insertions, 3 deletions
diff --git a/net/oor/Makefile b/net/oor/Makefile
index 581c6e66f..aac5cd230 100644
--- a/net/oor/Makefile
+++ b/net/oor/Makefile
@@ -17,8 +17,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=oor
PKG_VERSION:=1.3.0
-PKG_RELEASE:=2
-
+PKG_RELEASE:=3
PKG_SOURCE_URL=https://github.com/OpenOverlayRouter/oor/releases/download/$(PKG_VERSION)/
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -58,4 +57,4 @@ define Package/oor/install
$(INSTALL_BIN) $(PKG_BUILD_DIR)/openWRT/openwrt.init.script $(1)/etc/init.d/oor
endef
-$(eval $(call BuildPackage,oor)) \ No newline at end of file
+$(eval $(call BuildPackage,oor))
diff --git a/net/oor/patches/010-gcc10.patch b/net/oor/patches/010-gcc10.patch
new file mode 100644
index 000000000..17242aa22
--- /dev/null
+++ b/net/oor/patches/010-gcc10.patch
@@ -0,0 +1,26 @@
+--- a/oor/data-plane/tun/tun.c
++++ b/oor/data-plane/tun/tun.c
+@@ -53,6 +53,8 @@ int tun_rm_fwd_from_entry(lisp_addr_t *eid_prefix, uint8_t is_local);
+ tun_dplane_data_t * tun_dplane_data_new_init(oor_encap_t encap_type, glist_t *allowed_dst_eids);
+ void tun_dplane_data_free(tun_dplane_data_t *data);
+
++int tun_receive_fd;
++int tun_ifindex;
+
+ data_plane_struct_t dplane_tun = {
+ .datap_init = tun_configure_data_plane,
+--- a/oor/data-plane/tun/tun.h
++++ b/oor/data-plane/tun/tun.h
+@@ -60,9 +60,9 @@
+
+ /* Tun MN variables */
+
+-int tun_receive_fd;
+-int tun_ifindex;
+-uint8_t *tun_receive_buf;
++extern int tun_receive_fd;
++extern int tun_ifindex;
++extern uint8_t *tun_receive_buf;
+
+ lisp_addr_t * tun_get_default_output_address(int afi);
+ int tun_get_default_output_socket(int);