aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2015-05-31 14:02:47 +0200
committerDaniel Golle <daniel@makrotopia.org>2015-05-31 14:13:58 +0200
commit70980bc50b2abf6a686754b12252ffa4399929e8 (patch)
tree5b92687ece2f8ec9920f2397a921c0860eb76590 /net
parent8e835c763a23d25c50962db2641910e219f5076f (diff)
gnunet: use upstream fix for libmicrohttpd detection
The autoconf issue when detecting libmicrohttpd was fixed upstream in SVN revision 35845. Use that and remove the dirty work-around. See also: https://gnunet.org/bugs/view.php?id=3805#c9201 Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'net')
-rw-r--r--net/gnunet/Makefile2
-rw-r--r--net/gnunet/patches/013-work-around-libmicrohttpd-detection.patch68
2 files changed, 1 insertions, 69 deletions
diff --git a/net/gnunet/Makefile b/net/gnunet/Makefile
index af8960c50..58808c0f9 100644
--- a/net/gnunet/Makefile
+++ b/net/gnunet/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=gnunet
-PKG_SOURCE_VERSION:=35844
+PKG_SOURCE_VERSION:=35845
PKG_VERSION:=0.10.1-svn$(PKG_SOURCE_VERSION)
PKG_RELEASE:=1
diff --git a/net/gnunet/patches/013-work-around-libmicrohttpd-detection.patch b/net/gnunet/patches/013-work-around-libmicrohttpd-detection.patch
deleted file mode 100644
index 74457ef2d..000000000
--- a/net/gnunet/patches/013-work-around-libmicrohttpd-detection.patch
+++ /dev/null
@@ -1,68 +0,0 @@
-Index: gnunet-0.10.1-svn35844/configure.ac
-===================================================================
---- gnunet-0.10.1-svn35844.orig/configure.ac
-+++ gnunet-0.10.1-svn35844/configure.ac
-@@ -854,14 +854,7 @@ AC_ARG_WITH(microhttpd,
- AC_CHECK_HEADERS([microhttpd.h],
- AC_CHECK_DECL(MHD_OPTION_PER_IP_CONNECTION_LIMIT,
- AC_CHECK_LIB([microhttpd], [MHD_get_fdset2],
-- [AC_MSG_CHECKING([for libmicrohttpd >= 0.9.32])
-- AC_RUN_IFELSE([AC_LANG_SOURCE([
-- #include "$native_srcdir/src/include/platform.h"
-- #include <microhttpd.h>
-- int main () { return MHD_VERSION >= 0x0093200 ? 0 : 1; }
-- ])], [
-- AC_MSG_RESULT(ok)
-- lmhd=1],[AC_MSG_RESULT(failed)],lmhd=0)]),
-+ ),
- [],[#include "$native_srcdir/src/include/platform.h"
- #include <microhttpd.h>]),,
- [#include "$native_srcdir/src/include/platform.h"])
-@@ -873,14 +866,7 @@ AC_ARG_WITH(microhttpd,
- AC_CHECK_DECL(MHD_OPTION_PER_IP_CONNECTION_LIMIT,
- AC_CHECK_LIB([microhttpd], [MHD_get_fdset2],
- EXT_LIB_PATH="-L$with_microhttpd/lib $EXT_LIB_PATH"
-- [AC_MSG_CHECKING([for libmicrohttpd >= 0.9.32])
-- AC_RUN_IFELSE([AC_LANG_SOURCE([
-- #include "$native_srcdir/src/include/platform.h"
-- #include <microhttpd.h>
-- int main () { return MHD_VERSION >= 0x0093200 ? 0 : 1; }
-- ])], [
-- AC_MSG_RESULT(ok)
-- lmhd=1],[AC_MSG_RESULT(failed)],lmhd=0)]),
-+ ),
- [],[#include "$native_srcdir/src/include/platform.h"
- #include <microhttpd.h>]),,
- [#include "$native_srcdir/src/include/platform.h"])
-@@ -891,19 +877,12 @@ AC_ARG_WITH(microhttpd,
- AC_CHECK_HEADERS([microhttpd.h],
- AC_CHECK_DECL(MHD_OPTION_PER_IP_CONNECTION_LIMIT,
- AC_CHECK_LIB([microhttpd], [MHD_get_fdset2],
-- [AC_MSG_CHECKING([for libmicrohttpd >= 0.9.32])
-- AC_RUN_IFELSE([AC_LANG_SOURCE([
-- #include "$native_srcdir/src/include/platform.h"
-- #include <microhttpd.h>
-- int main () { return MHD_VERSION >= 0x0093200 ? 0 : 1; }
-- ])], [
-- AC_MSG_RESULT(ok)
-- lmhd=1],[AC_MSG_RESULT(failed)],lmhd=0)]),
-+ ),
- [],[#include "$native_srcdir/src/include/platform.h"
- #include <microhttpd.h>]),,
- [#include "$native_srcdir/src/include/platform.h"])])
--AM_CONDITIONAL(HAVE_MHD, test x$lmhd = x1)
--AC_DEFINE_UNQUOTED([HAVE_MHD], $lmhd, [We have libmicrohttpd])
-+AM_CONDITIONAL(HAVE_MHD, test x1 = x1)
-+AC_DEFINE_UNQUOTED([HAVE_MHD], 1, [We have libmicrohttpd])
-
-
- # restore LIBS
-@@ -1655,7 +1634,7 @@ then
- fi
-
- # MHD
--if test "x$lmhd" != "x1"
-+if test "x1" != "x1"
- then
- AC_MSG_NOTICE([NOTICE: libmicrohttpd not found, http transport will not be installed.])
- fi