aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorAlexandru Ardelean <aa@ocedo.com>2014-09-18 16:06:23 +0300
committerAlexandru Ardelean <aa@ocedo.com>2014-09-18 17:21:57 +0300
commit6f1313abd0b4579ade7b075e9df989e46f369880 (patch)
treec16f4cf4b6e98a44a35642ee8f05b3887bbf4f04 /net
parent7d44d48c6698d2ee711392e3933f09375e11c2f4 (diff)
openvswitch: move openvswitch-common/postinst after install
Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Diffstat (limited to 'net')
-rw-r--r--net/openvswitch/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/net/openvswitch/Makefile b/net/openvswitch/Makefile
index e607d0fe7..c918fbcab 100644
--- a/net/openvswitch/Makefile
+++ b/net/openvswitch/Makefile
@@ -163,11 +163,6 @@ define Package/openvswitch-common/install
$(INSTALL_BIN) $(PKG_BUILD_DIR)/ovsdb/.libs/ovsdb-client $(1)/usr/bin/
endef
-define Package/openvswitch-common/postinst
-#!/bin/sh
-[ -n "$${IPKG_INSTROOT}" ] || /etc/init.d/openvswitch enable || true
-endef
-
define Package/openvswitch-switch/install
$(INSTALL_DIR) $(1)/usr/bin/
$(INSTALL_BIN) $(PKG_BUILD_DIR)/utilities/.libs/ovs-dpctl $(1)/usr/bin/
@@ -182,6 +177,11 @@ define Package/openvswitch-switch/install
$(INSTALL_CONF) $(PKG_BUILD_DIR)/vswitchd/vswitch.ovsschema $(1)/usr/share/openvswitch/
endef
+define Package/openvswitch-common/postinst
+#!/bin/sh
+[ -n "$${IPKG_INSTROOT}" ] || /etc/init.d/openvswitch enable || true
+endef
+
$(eval $(call BuildPackage,openvswitch-ipsec))
$(eval $(call BuildPackage,openvswitch-common))
$(eval $(call BuildPackage,openvswitch-switch))