aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorEneas U de Queiroz <cotequeiroz@gmail.com>2020-05-12 09:10:38 -0300
committerEneas U de Queiroz <cotequeiroz@gmail.com>2020-05-12 09:30:30 -0300
commit6df2abceca68c71e6a6366b29e5528da58bc4613 (patch)
tree52afe4ccdb894ff351b19304989bd4452cff590e /net
parent9697114b39dca0bf7530e2fa263a43df78c42e76 (diff)
libreswan: fix compilation with Linux 4.14
According to a comment in programs/pluto/kernel_xfrm_interface.c:177: * IFLA_XFRM_IF_ID was added to mainline kernel 4.19 linux/if_link.h with older kernel headers 'make USE_XFRM_INTERFACE_IFLA_HEADER=true' Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
Diffstat (limited to 'net')
-rw-r--r--net/libreswan/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/net/libreswan/Makefile b/net/libreswan/Makefile
index 2752fd997..ddc930431 100644
--- a/net/libreswan/Makefile
+++ b/net/libreswan/Makefile
@@ -81,6 +81,10 @@ MAKE_FLAGS+= \
FINALRUNDIR="/var/run/pluto" \
ARCH="$(LINUX_KARCH)" \
+ifdef CONFIG_LINUX_4_14
+ MAKE_FLAGS+= USE_XFRM_INTERFACE_IFLA_HEADER=true
+endif
+
define Build/Prepare
$(call Build/Prepare/Default)
$(SED) 's,include $$$$(top_srcdir)/mk/manpages.mk,,g' \